chkdsk /F on reboot doesn't happen


C

Chris

The Registry key
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControllerSet\Control\SessionManager
with name BootExecute has the following value:

autocheck autochk /p \??\C:
autocheck autochk *
SsiEfr.exe

which according to Microsoft has the correct first line to implement "chkdsk
/F" on reboot. Yes, I have run chkdsk as administrator -- yes, I have
rebooted it naturally, many times -- yes, I have also done a power button
drastic shutdown in case some nasty bug is watching the shutdown.

The reason for needing chkdsk is that it already shows disk errors whether I
use the "/F" option or not. It offers to schedule itself whenever I use
"/F".

Incidentally, this Registry key doesn't seem to change after reboot, so I
seem to have the opposite problem of some on this newsgroup who see chkdsk
run every time. I just want it to run at least once. Why doesn't "chkdsk
/F" happen on reboot?
 
Ad

Advertisements

M

michael56555

When I had this problem, I got it to scan by running msconfig and selecting
"safe boot" in the boot tab. Then going to properties for the C: drive and
selecting Check disk from there. That would work when nothing else would.
Even booting to safe mode by selecting it by pressing F8 at boot would not
work.

It appears that something was loading before the check disk command on
reboot. Never did figure out what that might have been. Problem corrected
when I went back to factory with a restore.
~Mike
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top