Can't open spreadsheet via shortcut



Example: Suppose I have a shortcut that points to C:\Program Files\Test

When I try to open this via double clicking the shortcut, it fails. I get
an error message:

Cannot open "C:\Program" followed by
Cannot open "Files\Test" followed by
Cannot open "Folder\abc.xls"

I can open this file directly by navigating to it using the Open menu. I
cannot open the file by navigating to it in Windows explorer and double
clicking it, same error as above. Any suggestions?

Thanks, Stuart


The path seems to be wrong. It should be something like:

"c:\program files\test\folder\abc.txt"


"c:\program" "files\test" "folder\abc.xls"

Try changing the path of your shortcut.

Let us know, if the information was useful.

Dave Peterson

Sometimes one of these works when you're having trouble with double clicking on
the file in windows explorer:

Tools|Options|General|Ignore other applications (uncheck it)

--- or ---

Close Excel and
Windows Start Button|Run
excel /unregserver
Windows Start Button|Run
excel /regserver

The /unregserver & /regserver stuff resets the windows registry to excel's
factory defaults.

Gord Dibben


Make sure you have double-quotes around the path.

"C:\Program Files\Test Folder\abc.xls"

If you do the regserver steps outlined by Dave P. this should get taken care

Gord Dibben MS Excel MVP


Gord, it has double quotes. And the same thing happens when I double click
the file name in Windows Explorer. The only way I can open a file right now
is to open excel, click on "File", "Open", and browse to the desired file.
Any other method produces the error.


Gord Dibben


Tools>Options>General uncheck "Ignore other Applications"
Exit Excel and try again.

If this doesn't work try to re-register Excel

Close Excel first and
On the Windows Taskbar

1) Start>Run "excel.exe /unregserver"(no quotes)>OK.
2) Start>Run "excel.exe /regserver"(no quotes)>OK.
See the space between exe and /regserver

You might have to designate a full path to excel.exe.
In that case Start>Run "C:\yourpath\excel.exe /regserver"(no quotes)>OK.

One more thing to try if any of the above brings no joy.........

Go to Start>Settings>Folder>Options>File Types. Scroll down to MS Excel
Worksheet. Then if running Win98 OS Edit> select "Open" and Edit.

If using WinXP OS you would scroll down to .XLS then "Advanced">Open>Edit.

In Command line the path should be similar to this....

you want Book1 to open.

You must have the double quotes.

Below have "use DDE" checked and this in the DDE message box....[open("%1")]

Application should read "Excel"(no quotes)



The unregister/reregister worked. All is now well.

Any idea how this might have occurred? It didn't happen to me, it happened
to an associate, who I believe has had this happen to her before.


Gord Dibben

Can't recall if anyone has ever figured out why Excel will occasionally lose its
file association and "unregister" itself.

Usually occurs after a re-build of the Operating System after some disaster or
voluntary changes.

Around here, we just have the fixes due to experience and prior knowledge of
similar problems.

Gord Dibben MS Excel MVP

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question