Cannot join Windows XP SP2 PC to 2000 Domain


Joined
Aug 2, 2007
Messages
2
Reaction score
0
I am having problems joining Windows XP SP2 on a Windows 2000 Domain. When I try to join it I get the below message on the client.
----------------------------------------------------------------------------
Note: This information is intended for a network administrator. If you are not your network's administrator, notify the administrator that you received this information, which has been recorded in the file C:\WINDOWS\debug\dcdiag.txt.

The domain name (DomainName) might be a NetBIOS domain name. If this is the case, verify that the domain name is properly registered with WINS.

If you are certain that the name is not a NetBIOS domain name, then the following information can help you troubleshoot your DNS configuration.

DNS was successfully queried for the service location (SRV) resource record used to locate a domain controller for domain (DomainName):
The query was for the SRV record for _ldap._tcp.dc._msdcs.(DomainName)
The following domain controllers were identified by the query:
dc2
dc1
Common causes of this error include:
- Host (A) records that map the name of the domain controller to its IP addresses are missing or contain incorrect addresses.
- Domain controllers registered in DNS are not connected to the network or are not running.
For information about correcting this problem, click Help.
--------------------------------------------------------------------------------
I tried running the nltest /dsgetdc:(DomainName) and I get
DsGetDcName failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN

I can add a Windows 2000 client to the domain on the same network but not any XP PC's. Running an NS Lookup looks good too.


C:\DOS>nslookup
Default Server: (DomainServer.DomainName)
Address: 10.64.1.21

I have also ran other Windows support tools and got the below info.

C:\Program Files\Support Tools>netdiag
...................................
Computer Name: MIS-03905
DNS Host Name: MIS-03905
System info : Windows 2000 Professional (Build 2600)
Processor : x86 Family 15 Model 2 Stepping 9, GenuineIntel
List of installed hotfixes :
KB873339
KB884020
KB885835
KB885836
KB885884
KB886185
KB887472
KB888302
KB890046
KB890859
KB891781
KB893756
KB893803v2
KB896358
KB896423
KB896424
KB896428
KB898461
KB899587
KB899589
KB899591
KB900485
KB900725
KB901017
KB901214
KB902400
KB904706
KB905414
KB905749
KB908519
KB908531
KB910437
KB911280
KB911562
KB911564
KB911565
KB911927
KB912919
KB913580
KB914388
KB914389
KB916595
KB917344
KB917422
KB917734_WMP8
KB917734_WMP9
KB917953
KB918118
KB919007
KB920213
KB920670
KB920683
KB920685
KB920872
KB921398
KB921883
KB922582
KB922616
KB922819
KB923191
KB923414
KB923689
KB923694
KB923980
KB924191
KB924270
KB924496
KB924667
KB925398_WMP64
KB925902
KB926255
KB926436
KB927779
KB927802
KB927891
KB928090
KB928255
KB928843
KB929123
KB929338
KB929969
KB930178
KB930916
KB931261
KB931768
KB931784
KB931836
KB932168
KB933566
KB935839
KB935840
KB936357
Q147222

Netcard queries test . . . . . . . : Passed

Per interface results:
Adapter : Local Area Connection
Netcard queries test . . . : Passed
Host Name. . . . . . . . . : MIS-03905.centralfreight.com
IP Address . . . . . . . . : 10.65.34.176
Subnet Mask. . . . . . . . : 255.255.255.0
Default Gateway. . . . . . : 10.65.34.1
Primary WINS Server. . . . : 10.64.1.21
Secondary WINS Server. . . : 10.64.4.21
Dns Servers. . . . . . . . : 10.64.1.21
10.64.4.21

AutoConfiguration results. . . . . . : Passed
Default gateway test . . . : Passed
NetBT name test. . . . . . : Passed
No remote names have been found.
WINS service test. . . . . : Passed

Global results:

Domain membership test . . . . . . : Passed
Dns domain name is not specified.
Dns forest name is not specified.

NetBT transports test. . . . . . . : Passed
List of NetBt transports currently configured:
NetBT_Tcpip_{8280CC47-FD12-463D-8FDB-5865A6244A7C}
1 NetBt transport currently configured.

Autonet address test . . . . . . . : Passed

IP loopback ping test. . . . . . . : Passed

Default gateway test . . . . . . . : Passed

NetBT name test. . . . . . . . . . : Passed

Winsock test . . . . . . . . . . . : Passed

DNS test . . . . . . . . . . . . . : Passed

Redir and Browser test . . . . . . : Passed
List of NetBt transports currently bound to the Redir
NetBT_Tcpip_{8280CC47-FD12-463D-8FDB-5865A6244A7C}
The redir is bound to 1 NetBt transport.
List of NetBt transports currently bound to the browser
NetBT_Tcpip_{8280CC47-FD12-463D-8FDB-5865A6244A7C}
The browser is bound to 1 NetBt transport.

DC discovery test. . . . . . . . . : Skipped

DC list test . . . . . . . . . . . : Skipped

Trust relationship test. . . . . . : Skipped

Kerberos test. . . . . . . . . . . : Skipped

LDAP test. . . . . . . . . . . . . : Skipped

Bindings test. . . . . . . . . . . : Passed

WAN configuration test . . . . . . : Skipped
No active remote access connections.

Modem diagnostics test . . . . . . : Passed
IP Security test . . . . . . . . . : Passed
Service status is: Started
Service startup is: Automatic
IPSec service is available, but no policy is assigned or active
Note: run "ipseccmd /?" for more detailed information

The command completed successfully
C:\Program Files\Support Tools>


----------------------------------------------------------------------
C:\Program Files\Support Tools>netdom join mis-03905 /Domain:cfl
The specified domain either does not exist or could not be contacted.
The command failed to complete successfully.
----------------------------------------------------------------------

C:\Program Files\Support Tools>nslookup domainname
Server: servername.cfl
Address: 10.64.1.21
*** servername.cfl can't find cfl: Non-existent domain
C:\Program Files\Support Tools>nltest /dsgetdc:cfl
DsGetDcName failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN


----------------------------------------------------------------------
NETSETUP.log
08/02 10:45:05 NetpValidateName: checking to see if 'cfl' is valid as type 3 name
08/02 10:45:07 NetpCheckDomainNameIsValid for cfl returned 0x54b
08/02 10:45:07 NetpCheckDomainNameIsValid [ Exists ] for 'cfl' returned 0x54b
08/02 11:18:06 -----------------------------------------------------------------
08/02 11:18:06 NetpValidateName: checking to see if 'cfl' is valid as type 3 name
08/02 11:18:17 NetpCheckDomainNameIsValid for cfl returned 0x54b
08/02 11:18:17 NetpCheckDomainNameIsValid [ Exists ] for 'cfl' returned 0x54b
08/02 11:21:46 -----------------------------------------------------------------
08/02 11:21:46 NetpValidateName: checking to see if 'CFL' is valid as type 3 name
08/02 11:21:48 NetpCheckDomainNameIsValid for CFL returned 0x54b
08/02 11:21:48 NetpCheckDomainNameIsValid [ Exists ] for 'CFL' returned 0x54b
08/02 11:28:26 -----------------------------------------------------------------
08/02 11:28:26 NetpDoDomainJoin
08/02 11:28:26 NetpMachineValidToJoin: 'MIS-03905'
08/02 11:28:26 NetpGetLsaPrimaryDomain: status: 0x0
08/02 11:28:26 NetpMachineValidToJoin: status: 0x0
08/02 11:28:26 NetpJoinDomain
08/02 11:28:26 Machine: MIS-03905
08/02 11:28:26 Domain: cfl
08/02 11:28:26 MachineAccountOU: (NULL)
08/02 11:28:26 Account: (NULL)
08/02 11:28:26 Options: 0x3
08/02 11:28:26 OS Version: 5.1
08/02 11:28:26 Build number: 2600
08/02 11:28:26 ServicePack: Service Pack 2
08/02 11:28:26 NetpValidateName: checking to see if 'cfl' is valid as type 3 name
08/02 11:28:37 NetpCheckDomainNameIsValid for cfl returned 0x54b
08/02 11:28:37 NetpCheckDomainNameIsValid [ Exists ] for 'cfl' returned 0x54b
08/02 11:28:37 NetpDoDomainJoin: status: 0x54b


I'm not sure what else to try. I have seen other issues on the internet sort of related and everyone says to look at DNS. Everything looks fine with DNS. Any other suggestions?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top