Bugcode usb with Belkin F5d7050 adapter



I'm running Windows Vista Home basic and I keep getting a failure of
the USB port where my Belkin F5d7050 wireless adapter is plugged in.

I have two usb ports built into the motherboard which are USB 2.0 and
two USB connections on the motherboard for extra USB ports, one of
which I am using. If the PC has been left on all day not being used
and I go to use it the network has been lost. If I then shutdown it
takes a long time to shutdown and then it blue screens with a
bugcode_usb error.

If I unplug the wireless adapter and plug it back into the same port
nothing happens, if I plug it into another USB port then it picks it
up as another adapter and I have to set it back up from scratch. If I
plug another USB device into the port the F5d7050 was plugged into
then it doesn't work - the port has been shudown.

In device manager I notice that it shows I have four USB hubs. The
wireless adpater is plugged into the same hub as the USB keyboard but
they show up under different hubs, I'm presuming this is because the
F5d7050 is being picked up as a USB 2 device and the keyboard is not.

I've tried different drivers, uninstalling all the USB devices and
letting Vista re-install all of them but I still get the same problem.
This problem also only affects the port the wireless device is plugged
into and no other - and it doesn't matter which port I use for the
device I still get the same problems.

Any help appreciated.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question