Association with .MSI files not working


Bill Karwin

I'm using Windows 2000 SP4, and it has forgotten how to run an .msi
file. When I double-click on an .msi file, or if one is launched from a
setup.exe application, it opens the .msi file in my text editor (vim).

I can right-click on an .msi and one of the context menu choices is
"Install". That runs the .msi and it seems to have the correct
association. But I can't just run an installer from its setup.exe,
which make me think that some environment or options might not be
getting set right.

I found this page with advice:

So I checked ftype and assoc, and everything appears to be correct:
C:\> ftype Msi.Package
Msi.Package="%SystemRoot%\System32\msiexec.exe" /i "%1" %*
C:\> assoc .msi

I also tried uninstalling Microsoft Installer and reinstalling it, but
this hasn't fixed anything.

Does this ring a bell with anyone? Is there a way I can restore my
system to associate .msi files correctly (short of an operating system

Bill Karwin

Bill Karwin

Stefan said:
When you right click an .msi file to bring up its contect menu: what is the default command (printed in bold)?

Aha! "VIM" is the default, bold command for this file. So this would
make sense why vim is used to open the .msi files by default. But how
can this be the case, if assoc and ftype show the correct entries?

Looking in the registry, I find
\HKEY_CLASSES_ROOT\Msi.Package\shell\Open\ has a value (Default) with
data "&Install". So that's where this option comes from in the context

When I installed vim, there was an optional registry script that created
"VIM" as an option in context menus, so I could edit virtually any file
from its context menu. So VIM appears in the context menu of all file
types. But for other file types, it is _not_ in bold.

How can I make the Install option be the bold/default one for Msi.Package?

Bill K.

Bill Karwin

Stefan said:
In Windows Explorer click Advanced -> Folder orptions (or something similar, I'm translating from German).
Go to the file types tab.
Select MSI as extension. Click Advanced.
Select Install and click "make default"

Hooray! That has solved the issue. Thank you very much. I appreciate
your clear instructions.

I thought I was at least competent at administering Windows NT/2000, but
I guess you can always learn something new.

Bill K.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question