Access 2003 / SQL Express 8 Can't Add Rows to Table



I created an ADP in Access 2003 to connect to SQL Server Express 8 and
succesfully made the connection.
I also succesfully imported a new table, but when I tried to add records to
the new table, I can not do it. I tried opening the table but the add new
record is disabled.

Then I tried to create an update query as the help states for ADP.

I received the following message:
You have connected to a version of SQL Server later than SQL Server 2000. The >version of Visual Studio or Access that you are using was released before the >version of SQL Server to which you are connected. For this reason, you might >encounter problems.

Please check with Microsoft to see if there is a service pack that you should apply >to Visual Studio or Office in order to get support for the version of SQL Server to >which you are connected.

I red that you cannot make design changes to SQL Server objects
( but is adding
rows to a table a design change?
Is it possible to make row additions to a table in this scenario?

Thank you in advance

Norman Yuan

Does the said table has a PK (since you just imported from somewhere,
especially if it is from a Jet database, it is possible that there is no PK
in that table)? For a table without PK, you cannot add record from Access
UI, but you can add record with "INSERT INTO...." code.


Thank you Norman.
I. Yes it didn't had a PK, but I tryed to add a record with "INSERT INTO..."
code, was not able to do it (while in the SQL Server Management Studio I
could do it with the code).
To make it through the code I use the procedure in the help under "Create an
update query (ADP)" in Access 2003. But when I go to the designer it gives me
the error I described originally. It doesn't allow me to drop tables, but
then I used the SQL code pane (didn't needed the graphical help this time),
once I wrote the code it didn't execute it (even though it parses it
correctly, with the "Verify SQL Syntax" buttom).
II. I also added a PK and tried both with the UI and the code.
Neither had worked so far. :(

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question