A2007 converted mdb database crashes



Hello - has this subject been covered in an earler post? I looked backward
as far as possible and didn't see it but it's hard to believe I'm the only
one in the world having this problem.

I'm trying to convert a split front-end/back-end A2002 mdb to the ACCDB
format using A2007 SP-1, running Vista. It's quite a complex app (about
50MB front end). The app runs fine as an mdb under A2007. But whenever I
tell A2007 to convert the front-end to ACCDB, it appears to work OK, with no
error messages. But when I try to open the new ACCDB it "crashes" Access.
The message is: "Microsoft Office Access Has Stopped Working".

I am able to open it if I hold down the shift (bypass) key while loading. I
can open different objects and modules in design mode. But as soon as I run
the autoexec macro it crashes. The autoexec macro simply loads a form, so I
attempted to step through the form startup code line by line, but it never
made it to the first line of code.

I'd like to add - the mdb had Access security enabled. I'm told I should
ignore this in the ACCDB. Is this true? I don't specify a username or an
..mdw in the startup.

Where should I go from here?

thanks- Derek


What may be your problem is that user level security is not available in
ACCDB files. You have to use the MDB format in order to use ULS with Access
Bob Larson
Access World Forums Super Moderator
Utter Access VIP
Tutorials at http://www.btabdevelopment.com
If my post was helpful to you, please rate the post.

Allen Browne

1. Open the MDB. Remove any password on the VBA code (not the same as

2. Make sure the Name AutoCorrect boxes are unchecked.

3. Decompile the database. (This is probably the main issue.)

4. Compact.

Now try converting again.


Hi Allen
Thanks for the response

Yes it's voodoo programming. Strange rituals seem to work. I tried your
No.1 is non applicable as there is no code password.
No.2 also N/A as the boxes were already unchecked.
No. 3. I decompiled/recompiled but it didn't seem to help.
Then quite by accident I discovered if I opened a module and manually ran
any one small sub by putting the cursor in it and pressing F5... the problem
was cured.
(I think this only works if you first say a chant over some chicken bones


Allen Browne

Okay: so making a change has the same effect as decompiling, which triggers
creating the binary for the new version.

Make sure you have Compile On Demand unselected under Tools | Options in the
code window.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question