0x800f0900 with SP2 install



The morning of 7-8 my laptop was shutdown, when I booted up Windows informed
my that updates had been installed. When I started using the computer I
noticed certain programs did not work and I could not access certain
programs. I tried to research the problem. Checked for malware using MS
online OneCare and tried to reinstall IE8. Upon reboot the system would not
start so I attempted a boot from DVD and repair. It could not repair but did
a restore to earlier time. I researched some more and found that my laptop
was running at SP1. When I attempted to upgrade to SP2 through Windows
Update. After the update completed the computer would not start, again I
booted to the DVD and attempted a repair. It could not repair but did a
Some software that did not work include MapPoint 2009, light scribe, HP OCR.
Some hardware that did not work include the DVD (had to change registry
settings per
http://www.fixya.com/support/t529074-hl_dt_st_dvdram_gsa_t20l_ata_device_not), external speakers.
I downloaded SP2 and attempted to install the Service Pack only to come up
with error 0x800f0900.
I went to http://support.microsoft.com/kb/947366 then downloaded and ran
System Update Readiness Tool(KB947821).

Ran SP2 from the DVD again and received the following
A system error prevented the service pack from installing. Please
download and runt the "Check for System Update Readiness" tool at
Reapplied System Update Readiness tool
Ran SP2 from the DVD again with the same result



Ran sfc /scannow

Result Windows Resources Protection found corrupt files but was unable to
fix some of them – Detail are included in the CBS.loc windir\logs\cbs\cbs.log
I can send the loggs if needed

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question