How do I use Stunnel to make courier work with gmail

Discussion in 'Freeware' started by SamF., Jul 18, 2006.

  1. SamF.

    SamF. Guest

    Use Stunnel to make courier work with gmail is what I hear suggested. I
    don't have a clue about how to set up stunnel. Are there directions
    located someplace so that I can get this working with out having any
    idea of what I am doing?
     
    SamF., Jul 18, 2006
    #1
    1. Advertisements

  2. SamF.

    Ben Guest

    In article <>,
    says...
    > Use Stunnel to make courier work with gmail is what I hear suggested. I
    > don't have a clue about how to set up stunnel. Are there directions
    > located someplace so that I can get this working with out having any
    > idea of what I am doing?
    >


    http://www.rosecitysoftware.com/Courier/faq/configure-3.html explains
    exactly what you need to do for mail servers requiring SSL. Use the
    settings given in GMail help in conjunction with the instructions above.
     
    Ben, Jul 18, 2006
    #2
    1. Advertisements

  3. SamF.

    RockFox

    Joined:
    Mar 21, 2008
    Messages:
    1
    Likes Received:
    0
    Last edited: Aug 31, 2008
    RockFox, Mar 21, 2008
    #3
  4. SamF.

    galenwollenberg

    Joined:
    Dec 1, 2011
    Messages:
    1
    Likes Received:
    0
    i spent quite literally 2 weeks trying to get stunnel to work so my canon copier would talk to gmail.

    the problem was that i could enable SSL on the canon copier but i could not change the port. so it wouldnt talk to gmail.

    here is my stunnel.conf for any one who is having as much trouble as i did getting stunnel and gmail to work. the gmail account has pop/imap enabled in the mail settings in gmail. 192.168.150.2 is my internal windows server running stunnel. i could not get 127.0.0.1 to work. i just put my stunnel servers ip in the copier as the mail server 192.168.150.2. also i think i had to turn off smtp auth on the copier for it to work. your mileage may vary...

    just copy paste this into your stunnel.conf for gmail.


    cert = stunnel.pem
    socket = l:TCP_NODELAY=1
    socket = r:TCP_NODELAY=1
    client = yes


    [pop3s]
    accept = 110
    connect = pop.gmail.com:995

    [imaps]
    accept = 143
    connect = imap.gmail.com:993

    [ssmtp]
    accept = 25
    connect = smtp.gmail.com:465
     
    Last edited: Dec 1, 2011
    galenwollenberg, Dec 1, 2011
    #4
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mel
    Replies:
    0
    Views:
    521
  2. Frank Bohan

    Dark Courier

    Frank Bohan, May 5, 2005, in forum: Freeware
    Replies:
    0
    Views:
    392
    Frank Bohan
    May 5, 2005
  3. Chrissy Cruiser

    Stunnel And Squid

    Chrissy Cruiser, Jun 6, 2005, in forum: Freeware
    Replies:
    8
    Views:
    1,632
    rocky
    Jun 7, 2005
  4. Demetris
    Replies:
    0
    Views:
    439
    Demetris
    Sep 7, 2005
  5. NoWhereMan

    Courier email

    NoWhereMan, Nov 1, 2005, in forum: Freeware
    Replies:
    0
    Views:
    191
    NoWhereMan
    Nov 1, 2005
Loading...

Share This Page