Data Execution Prevention problem

Discussion in 'Windows XP' started by quaf_man_dan, Jun 18, 2009.

  1. quaf_man_dan

    quaf_man_dan

    Joined:
    Oct 3, 2005
    Messages:
    15
    Likes Received:
    0
    hi,



    first off in case it matters my rig is:

    ASUS M2N68-CM

    AMD

    Athlon 64 Socket AM2 LE-1640 (2.6GHz)

    Crucial 1GB DDR2 800MHz/PC2-6400 Ballistix

    7600GT gfx card (can't remember brand off hand)

    Win XP Pro SP2





    just had a problem with my PC last night, was clearing up my desktop and (due to a dodgy mouse button) accidentaly double clicked on an .exe file (was a setup for a utility to tell me details of an avi). As soon as I had done this I had a window pop up that I hadn't seen before:



    Data Execution Prevention

    to help protect your computer windows has closed this program

    Name: windows explorer

    Publisher: Microsoft corporation



    when this happened the taskbar/start menu/all desktop items disappeared and didn't come back, the firefox windows I had open worked still and I could alt-tab between them fine, just not do anything else much.



    I restarted through task manager, however once the PC booted up again I quickly realised this appears to be happening for any and all .exe I try to run....



    checked in control panel and DEM is set to essential Windows programs and services only.



    haven't really got much of a clue about DEM so thought I'd ask here and see if anyone has any ideas.



    Cheers,



    Dan
     
    quaf_man_dan, Jun 18, 2009
    #1
    1. Advertisements

  2. quaf_man_dan

    Madxgraphics

    Joined:
    Apr 19, 2008
    Messages:
    4,081
    Likes Received:
    0
    Location:
    In A house
    Hi Dan
    Welcome to the forum [​IMG]

    Here's a link about DEP
    http://support.microsoft.com/kb/875352
    I'd suggest foing a system restore to a time beforeyou double clicked this program, then go and remove it . Run your AV to see if you have picked up a virus or the like..
     
    Madxgraphics, Jun 18, 2009
    #2
    1. Advertisements

  3. quaf_man_dan

    quaf_man_dan

    Joined:
    Oct 3, 2005
    Messages:
    15
    Likes Received:
    0
    hey, sorry took so long to get back to you - family illness has left little time for sorting the PC....

    tried to do a system restore and got as far as selecting the date for the restore and hitting OK, then got a dialogue box that said

    "system restore is not able to protect your computer. Please restart your computer, and then run system restore again."

    so I restarted went into the start menu to do retry the restore but as soon as I hit system restore got the same message.

    Also while it still won't let me run any .exe setup files .exe files that were already installed are working fine. Additionally my task bar/start menu etc now looks like windows 95 for some reason....


    edit 29/6 - problem has been resolved; thank you avast AV :D
     
    Last edited: Jun 29, 2009
    quaf_man_dan, Jun 27, 2009
    #3
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. mishaq
    Replies:
    5
    Views:
    2,383
    mishaq
    Jan 2, 2008
  2. ccvalentine

    MS Excel Data Label Problem

    ccvalentine, Dec 18, 2007, in forum: Windows XP
    Replies:
    0
    Views:
    392
    ccvalentine
    Dec 18, 2007
  3. NetSport

    Fatal Execution Engine Error (ox7925dc14)

    NetSport, Jan 2, 2008, in forum: Windows XP
    Replies:
    1
    Views:
    583
    GameMaster
    Jan 2, 2008
  4. wally.randall

    Batch execution of Excel with auto refresh

    wally.randall, Jun 24, 2008, in forum: Windows XP
    Replies:
    0
    Views:
    464
    wally.randall
    Jun 24, 2008
  5. Michael Bonde
    Replies:
    3
    Views:
    3,355
    moonlit801
    Jan 30, 2010
Loading...

Share This Page