zeroes being truncated


Z

ZenMasta

Hi, I have a tab delimited file that has products that I import into design
software and I am having a problem opening it in excel because the product
codes sometimes lead with zeroes. How can I open the file without getting
rid of the zeroes? I can open the file with notepad and see all the product
codes normally, just not in excel.

Currently I'm having to open the text file in note pad, copy everything.
paste into excel. Delete the data format the one column as text, and then
paste again.

Is there an easier way?
Thanks
 
Ad

Advertisements

B

Bernard Liengme

1) Have you tried giving the cells a custom format like: 00000000000
Or
2) can you prefix the product codes with single quote (aka apostrophe) so
the Excel treats it as text
Or
3) have you tried renaming the file to give it the extension TXT, then you
have more control of the import
best wishes
 
Z

ZenMasta

It already has a .txt extension. I don't want to add a single quote because
it would be hassle when I bring it into the design software. I guess my way
is okay I just thought there might have been a preference I could enable so
I could just import as is. ie. import all columns as text instead of it
trying to guess the format.
 
Ad

Advertisements

J

joeu2004

Hi, I have a tab delimited file [...].
How can I open the file without getting rid of the zeroes?

In Excel 2003 (at least), you can use Data>Import External Data>Import
Data. Use Next to get to the third menu. There, you can format each
column as Text before it is imported.

After I use Import Data, I go to Insert>Name>Define and delete the
"data" name that was created. I have never found it useful; more to
the point, it often causes problems.

HTH.


----- original posting -----
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top