XP to Vista (ide/sata) Mystery



My old XP pc died with a case of capacitor plague.

I replaced it with a Vista pc. I thought that I would have no problem moving
my data because on my other setup, I had kept all of my 'stuff' on a separate
HDD (partitioned into 4 parts).

Once I had gotten my Vista up & running, I felt ready to move-in my data
drive from the xp machine. When I cracked open the case, I found that it was
a sata setup -- my data drive was ide.

I got this Addonics IDE to Serial ATA Converter to 'make it work'. This
converter is a small circuit board that plugs into the ide connection on the
hard drive. You use all leads from a Y power plug to power the ide hard
drive & the circuit board (the circuit board uses the small floppy) a sata
wire plugs into the circuit board & into your motherboard. I changed the
mode select from cable to master. (as directed in the feeble instructions)

On my motherboard there are 4 sata plugins. #1 is my primary HDD. #2 was my
DVD. I plugged the converted ide drive into #3.
When I started up Vista. I got a black screen. I let it set for about 3-4
Then I got worried. I tried to enter bios setup but nothing happenned. I
waited another 3-4 minutes. Got really worried so I turned the pc off &
disconnected the ide converter setup. Started Vista without any delay, no
warnings that the computer was shut down improperly. Yeah !! NOT.....

I still needed my data. So, I got a ide to usb wire setup from Sabrent that
has its own power supply. I hooked the ide drive up to it & started Vista. It
saw the drive but didn't give it a drive assignment. It wasn't listed in
device management (just device manager) & you couldn't see it in Computer.

So, confused. I moved the ide drive to usb wire setup to my XP laptop to see
if I could see it. Got the same results that I had with Vista.

Took the ide back to my dead XP == bios recognizes the drive when though the
machine no longer boots up. Ran a dos Seagate drive analysis on the ide
drive. It checked out ok. It says the the partition is present but gives no

I took my old C:\ drive out of the dead pc & hooked it up to the ide/usb
wire setup to my XP laptop -- just to see if it the ide/usb wire setup was
faulty. It wasn't. Files from the drive popped right up for viewing like it
was a music cd....

Tried my data drive again. No change. No viewable data. No drive number. No
access from disk management.

Got Partition Recovery for Dos (demo) & hooked the data ide back up to the
dead pc for a look see. It saw the C:\ drive. It saw the data drive. BUT,
it said the data drive was unassigned. I've been letting it run an extended
search for a partition for about 6 hours now. It still says that it's found 0

I have not a clue what could have happenned to the data drive partitions. I
don't have a way now to run windows on an ide drive. I'm afraid to hook it
back up to Vista using the converter.

Partition Recovery for Dos instructions did kind of make me wonder if it
only detected system partitions... & if Partition Recovery for Windows only
detected non system partitions. ANY body know??

My old XP died while I was on the internet. It froze. I rebooted. I never
got my system back afterwards. Just the dreaded blue screen message & then
the notice that to avoid further damage to my system, windows was shutting
down. There is NO doubt that capacitors were bulging, slightly leaking &
discolored. I assume that was the problem after reading about it & finding no
other viable remedy.

Point being, I was not in anyway accessing my data drive when the machine
went down. As a matter of fact, I had immediately disconnected the drive so
that I wouldn't mess her up while I rebooted, rebooted, tried system recovery
& the like before I found the capacitor problem.

Odd thing about Partition Recovery is that it claims the data drive has 75g
-- but its an 80g drive. I'm wondering if my partitions are still intact but
PC is unable to detect them using their DOS version of the program.

I can't seem to find another program that runs strickly out of DOS at bootup.

I need some clues or direction to go next. ANYBODY ?? Please.

Oh yeah, as you can tell. No backup. Didn't have any more internal space &
my usb external drives have never worked on my xp desktop -- so I blew them
off as wasted purchases.....

Dominic Payer

It seems the Addonics is not compatible with your motherboard and/or drive.

Connect the drive to your IDE/USB device and start Vista.
Go to Disk Management and see if the disk is recognised. If it is, assign a
drive letter and it will then appear in Computer.


I guess that you got lost in my long windedness....
Been there. Did that. I tried the ide/usb on vista before i tried it on my
xp laptop.
It wasn't recognized on either. Thats why/where I decided to look into the
partition possibilities. I was afraid that the time I had the ide/sata hooked
up it was writing or changing the ide drive.... Any clue about the partition

Nate Grossman

Confused said:
I guess that you got lost in my long windedness....
Been there. Did that. I tried the ide/usb on vista before i tried it on my
xp laptop.
It wasn't recognized on either. Thats why/where I decided to look into the
partition possibilities. I was afraid that the time I had the ide/sata hooked
up it was writing or changing the ide drive.... Any clue about the partition

Yeah... shitcan the DOS partition manager and get something more


Dominic Payer

You have established that the IDE/USB device works correctly with your old C

Are you certain that your new system has no IDE connector? Review the specs
for whichever motherboard it contains to find out. Sometimes IDE connectors
are on the edge of the board facing outwards.

Since you have had hardware problems, particularly with capacitors, there
have almost certainly been power fluctuations for some time. Such
fluctuations can damage the drive and/or the data structure on it.

Drive failure could be co-incidence, and not related to the system problem.

1. Are any of the IDE drive pins bent or broken?
2. Run a full set of the drive manufacturer's diagnostics to discover
whether any part of the drive is reported damaged. Be sure to include a
surface test, but do not let the program repair the drive. Repair is often a
low-level format which would destroy your data.
3. If the above reveal no fault, it is the partition table and/or the Master
File Table which is damaged. You need either a competent local specialist to
repair the partition table or a data recovery specialist. Amateur and/or
incompetent attempts to recover the data could make an expensive trip to a
data recovery specialist essential.


yes. when i take out the system (c:\) drive from the dead xp & attach it to
the laptop xp using the ide/usb cable i am able to read the c:\ drive files
just as if it were a music cd or such... it has a drive letter assignment.

yes. i am certain that my new vista pc does NOT have an ide connector. it
does have a fdd1 connector(floppy) but that doesn't help me a bit. the
motherboard is a ms-7525.

there are NOT any bent, broken or otherwise visible defects in the ide pins.
i know that the ide/usb cable works because i can use it successfully with
the other ide (c:\) drive.

i have run a seagate diagnostic on the ide data drive (like a said
originally). i ran the full diagnostic. it checked out on every aspect ok.
the data drive is a maxtor MX6L080J4. the check indicated that a partition
was "present" but it gives no other specifics. (seagate & maxtor are one in
the same these days as i understand it)

i honestly don't think that drive is bad. i have never had a problem with
seagate telling me that my drive was failing in the past -- if it was. for
this instance, it is checking out OK.

odd though that it says that a partition is present -- where partition
recovery says that the drive is "unallocated". the extended search for a
partition by partition recovery i gave up on... i don't think that it was
ever going to finish after running in dos for 8 hours... i certainly don't
want to create any more problems on the drive than necessary even though the
partition recovery is just a trial version and thus can effect zero changes
to the drive.

i do feel that it is possible that the partition were somehow damaged from
the hookup to the addonics ide/sata board --i can think of no other viable
scenerio at the moment -- but believe me, i am no expert. if i were -- i
probably would have tried the addonics thing out on the dead xp c:\ drive
first. i don't care a thing about that system or the files on the disk. LIVE

in partition recovery you can visualize the drive in hexidecimal -- i guess
its hexidecimal, all i see are 00's throughout each sector -- expect on the
beginning of each sector which is 01. means nothing to me. i've jumped
through the disk ... but just to sector 55000 (its really slow in dos) but
that's really not very far in the scheme of 80g.

it just bothers me that seagate says a partition is present. partition
recovery says there isn't one --but partition recovery sets the drive at 75g
-- when it is an 80g drive. i'm hoping that my partition is still intact in
that 5g (i guess)

after seeing all of the 00 in partition recovery sectors... i'm afraid that
the drive is blank thoughout. seems to me that if you can delete files &
recover them.... if you can reformat a drive & recover files..... THEN THERE
OUGHT TO BE A WAY FOR ME TO GRAB MY DATA. i want so desparately to believe
that this is not hopeless.


Thanks for the link. I just ordered one of these to give 'her a try.

I have a question about your experience with converters -- is it possible
that it damaged the partition of the ide? I don't understand what I'm seeing
out of my seagate, partition recovery, ide/usb exercises.... my ultimate fear
is that the data has somehow been zapped. Any experience there?

I am not giving up yet........Just trying not to panic.


Ok-- just thinking here....

Dos doesn't recognize NTFS does it? That being TRUE, then partition
recovery would NOT be able to find the partitions because.... they are NTFS?
OR are all
partitions written is FAT formats?

Confused...is more confused.

Dominic Payer

It seems the disk is good but the partition table is damaged. Your data
should be recoverable if the disk partition table can be repaired, though
the data might be damaged.

Any operating system can read the partition table and know how many, and
what size, partitions there are. The OS will not be able to read the
contents of a partition if it does not include the necessary drivers.

The partition recovery program you have is not able to analyse the partition
table correctly. You said there were 4 partitions on the disk and it can see
only 1 and it cannot analyse that correctly. Such recovery programs can only
deal with known types of partition table corruption. The problems you have
had are likely to cause unusual damage to the partition table.

You need someone who can use a hex editor to repair the partition table
directly. It is beyond your ability to do this and while there might be a
program which could do the job you would only find it by luck, if it exists.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question