xp sr-2 firewall modifications


L

lev

Hello,
I'm trying to enable remote admin on the firewall through the netfw.inf
file. I have tried the wfinf_guide from microsoft but the entry regarding
remote admin doesn't seem to work.
http://www.microsoft.com/downloads/...1d-2f97-4e63-a581-bf25685b4c43&displaylang=en

HKLM,"SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\RemoteAdminSettings","Enabled",0x00010001,1

I have also tried to open ports 135 TCP and 445 TCP. Although they open
correctly remote admin still doesn't work. As soon as I manually turn off
the firewall remote admin works without any problems.

Has anyone managed to get this to work successfully? If so how?

Tnx
 
Ad

Advertisements

D

David Beder [MSFT]

please verify that the firewall believes it is supposed to use the Domain
profile.
ie "netsh firewall show currentprofile" would need to say Domain and not
Standard.
 
L

lev

I actually put it in both profiles and it doesn't work. I discovered that
the remote desktop has to be in the standard profile and can be changed
using



Netsh firewall set service remotedesktop enable

Or

Netsh firewall set service type = remotedesktop mode = enable scope = all
profile = standard



If you set it to profile = domain it will fail if the computer is part of a
domain or not.

I never did get the inf file modification to work.

Tnx anyways David.
 
Ad

Advertisements

D

David Beder [MSFT]

did you want RemoteDesktop or RemoteAdministration? they are two different
beasts with their own sets of regkeys.

--
David
Microsoft Windows Networking
This posting is provided "AS IS" with no warranties, and confers no rights.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top