XP Home gets "Access denied" when connecting to Vista RC1


Jerry Solomon

I have a small LAN at home.
I have the Vista RC1 machine, which I have several folders, and a printer

When I try to connect from an XP Home computer in the smae workgroup, I get
the "Access denied" message. I know with XP pro, I had to enable guest
account, or something along those lines because of the forceguest feature of
XP home. The Vista computer can read and write to the shares on the XP home
Can anyone shed some light on my issue, and what the resolution may be?

Here is what I already tried:
[from xp]
start--run \\uncpath
[on Vista]
1. Added LocalAccountTokenFilterPolicy to registry

2. Added other computer to local security policy: can access this computer
from the network

3. Removed guest from local security policy: deny access to this computer
from the network

4. In local security policy: Disabled Network access: do not allow
anonymous enumeration of sam accounts

Jerry Solomon

I failed to mention that I tried these obvious things as well:

1. Ensure username and password is created on the Vista machine that matches
the other machine

2. Ran the networking wizard and set file sharing to require a user account
on this machine

3. Ran the networking wizard to set file sharing to allow anyone on the
network to connect


Jerry Solomon

I still need to undo the steps I performed one-by-one to determine which
were necessary, but I had to enable the guest account on the Vista
machine--I had though I already did this, but perhaps this was a combination
of issues: I assume the local security policy "deny access to this computer
from the network" was necessary and somehow, this change disabled Guest

Now it is working--this was indeed related to the old "ForceGuest" issue
with XP home edition.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question