Word 2007 Style will not apply


C

cayce

I have a style that won’t apply properly in Word 2007. Here’s my process:
1. Copied text and pasted special as unformatted text.
2. Converted text to table.
3. Selected entire table and choose clear all from styles pane. Applied the
body style I wanted. This body style is built on no style.
4. The styles pane shows the body style I applied, but all of its
characteristics are changed.
5. Tried reapplying the style and it won’t revert to its definition.
6. Tried overwriting the body style from another healthy file: it makes no
difference.
7. Tried just placing my cursor in a table cell and clearing style/applying
style. The body style still has all of its characteristics changed. (Plus,
this would be an inefficient fix even if it worked.)

Reveal formatting pane shows the body style is applied but it also shows the
default font as Times New Roman 10 pt. The Normal style in this document is
actually 11 point Calibri. The font defined in the body style 10 pt Arial.

What is going on here?
 
Ad

Advertisements

S

Stefan Blom

Try changing the document default font (on the Set Defaults tab of the
Manage Styles dialog box) and see if that helps.

Note that the underlying problem is that there is a conflict between font
settings in paragraph styles and table styles (see
http://www.shaunakelly.com/word/tablestyles/index.html). Although this may
be a design choice, it can equally well be considered a bug, in my opinion.
 
C

cayce

Stefan:

Thanks for the direction. The document default font was set to Arial 10 pt.

The reveal formatting does show Table Style Table Grid 1 applied. When I
look at the settings in the table style, that's where the font and alignment
changes were coming from. I don't know how this was invoked. Is there a way I
can STOP Word automatically applying the table style that I didn't ask for or
want#$%^&^&.? I have to convert text to table often, but this is the first
time I've encountered this.
 
S

Stefan Blom

All tables have a table style in recent versions of Word; that cannot be
changed. Have you tried modifying the font of the table style as well as the
document defaults?
 
C

cayce

Yes..I was able to change it. I didn't realize that all tables have a style
applied, like it or not. I never noticed this before since this is the first
time I've run into this kind of conflict.

I suppose I can just make the Normal.dotm default table style's text match
the paragraph style I want used in tables so I don't go through this again.

Thanks for helping me once again.

Peace
 
S

Stefan Blom

I'm glad you got it sorted--and thank you for the feedback.
 
Ad

Advertisements

S

Stefan Blom

Thank you for providing the additional information. Not that you haven't
told us before, but it is certainly worth repeating! -:)

--
Stefan Blom
Microsoft Word MVP



Pamelia Caswell via OfficeKB.com said:
The built-in table normal (& therefore table grid) style is based on the
document defaults. So if the fonts for table grid and document defaults
differ, it is likely because someone changed the table style.

A fix is to make sure your table style does not specify font settings that
differ from the normal paragraph style when normal and document default
font
differ. You can do this several ways: 1. Edit the table grid style making
sure that the font face and size, line spacing, etc., are the same as
document defaults. 2. Delete the table grid style from the document--Word
keeps the style in the gallery but with its formatting reset to the as-
built-in status. Then reapply the table grid style.

Actually, the advice from the MS Word Team is to make normal and the
defaults agree, then set table styles the way you like. When I follow
that
advice I do not see the problem you are having. But I was able to
duplicate
your results, by deliberately not following the advice. ---So if the
table
style font is what you want, you could just change normal or the document
defaults. But since it is not, you really should change the table style
and
normal.

Pam





Stefan:

Thanks for the direction. The document default font was set to Arial 10
pt.

The reveal formatting does show Table Style Table Grid 1 applied. When I
look at the settings in the table style, that's where the font and
alignment
changes were coming from. I don't know how this was invoked. Is there a
way I
can STOP Word automatically applying the table style that I didn't ask for
or
want#$%^&^&.? I have to convert text to table often, but this is the first
time I've encountered this.
Try changing the document default font (on the Set Defaults tab of the
Manage Styles dialog box) and see if that helps.
[quoted text clipped - 28 lines]
What is going on here?
 
B

Beth Melton

The fact that it's recommended to leave the Normal style unchanged and
modify the document defaults instead for Word 2007 is advice that should be
repeated several times a day. IMHO at least. ;-)

~Beth Melton
Microsoft Office MVP

Pamelia Caswell via OfficeKB.com said:
And here I thought no one was listening. Seriously, I wouldn't have
posted
if I'd known you had answered. (My dog demanded a walk just before I
finished my post. When I came back I clicked send before checking to see
if
anyone had already answered.) Apologies.

Pam

Stefan said:
Thank you for providing the additional information. Not that you haven't
told us before, but it is certainly worth repeating! -:)
The built-in table normal (& therefore table grid) style is based on the
document defaults. So if the fonts for table grid and document defaults
[quoted text clipped - 43 lines]
What is going on here?
 
Ad

Advertisements

S

Stefan Blom

No need to apologize. Your *explanation* was better than mine.

--
Stefan Blom
Microsoft Word MVP




Pamelia Caswell via OfficeKB.com said:
And here I thought no one was listening. Seriously, I wouldn't have posted
if I'd known you had answered. (My dog demanded a walk just before I
finished my post. When I came back I clicked send before checking to see if
anyone had already answered.) Apologies.

Pam

Stefan said:
Thank you for providing the additional information. Not that you haven't
told us before, but it is certainly worth repeating! -:)
The built-in table normal (& therefore table grid) style is based on the
document defaults. So if the fonts for table grid and document defaults
[quoted text clipped - 43 lines]
What is going on here?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top