Windows Workflow Foundation / Web Service


R

Rob Dean - MCP

I am in the process of creating our first workflow project and am receiving
an error. It is a Sequential Workflow and it contains
a Web Service Input Activity, a Code Activity, and a Web Service Output
Activity. The workflow builds fine and when I run without
debugging, I get the default wsdl interface. I enter general data in to the
argument fields and get this error:

System.TypeLoadException: Could not load type
'System.Workflow.Runtime.Hosting.ManualWorkflowSchedulerService
' from assembly 'System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35'.
at System.RuntimeTypeHandle._GetTypeByName(String name, Boolean
throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark&
stackMark, Boolean loadTypeFromPartialName)
at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean
throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark&
stackMark)
at System.RuntimeType.PrivateGetType(String typeName, Boolean
throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark&
stackMark)
at System.Type.GetType(String typeName, Boolean throwOnError)
at
System.Workflow.Runtime.WorkflowRuntime.AddServiceFromSettings(WorkflowRuntimeServiceElement serviceSettings)
at
System.Workflow.Runtime.WorkflowRuntime.PrivateInitialize(WorkflowRuntimeSection settings)
at System.Workflow.Runtime.WorkflowRuntime..ctor(String configSectionName)
at
System.Workflow.Activities.WorkflowWebService.get_CurrentWorkflowRuntime()
at System.Workflow.Activities.WorkflowWebService.Invoke(Type
interfaceType, String methodName, Boolean isActivation, Object[] parameters)
at SharedWorkflow.MathServiceWorkflow_WebService.DivideNumbers(Double
dividend, Double divisor) in
C:\Users\rdean\AppData\Local\Temp\k0ca55is.cs:line 0


The Web.Config looks like this:


<?xml version="1.0"?>
<configuration>

<configSections>
<section name="WorkflowRuntime"
type="System.Workflow.Runtime.Configuration.WorkflowRuntimeSection,
System.Workflow.Runtime, Version=3.0.00000.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" />
</configSections>

<WorkflowRuntime Name="WorkflowServiceContainer">
<Services>
<add
type="System.Workflow.Runtime.Hosting.ManualWorkflowSchedulerService
, System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35"
UseActiveTimers="true"/>

<!-- <add
type="System.Workflow.Runtime.Hosting.DefaultWorkflowCommitWorkBatchService
, System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35" /> -->

<add type="System.Workflow.Runtime.Hosting.SqlWorkflowPersistenceService
, System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35"
UnloadOnIdle="true"
LoadIntervalSeconds="5"
ConnectionString="Initial Catalog=WorkflowPersistance;
Data Source=SLCQCSQL;
Integrated Security=SSPI;"/>
</Services>
</WorkflowRuntime>

<appSettings/>

<connectionStrings/>

<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="false"/>
<!--
The <authentication> section enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<!--
The <customErrors> section enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm"/>
<error statusCode="404" redirect="FileNotFound.htm"/>
</customErrors>
-->

<httpModules>
<add type="System.Workflow.Runtime.Hosting.WorkflowWebHostingModule,
System.Workflow.Runtime, Version=3.0.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" name="WorkflowHost"/>
</httpModules>

</system.web>

</configuration>

Please let me know what I am doing wrong. All of the information I can find
confirm all of my settings for the config section for the
ManualWorkflowSchedulerService. Is there some set-up I am missing or some
setting that is not obvious?

Thanks,

Rob Dean
(e-mail address removed)
 
Ad

Advertisements

R

Rob Dean - MCP

Does anyone know of this issue???

Rob Dean - MCP said:
I am in the process of creating our first workflow project and am receiving
an error. It is a Sequential Workflow and it contains
a Web Service Input Activity, a Code Activity, and a Web Service Output
Activity. The workflow builds fine and when I run without
debugging, I get the default wsdl interface. I enter general data in to the
argument fields and get this error:

System.TypeLoadException: Could not load type
'System.Workflow.Runtime.Hosting.ManualWorkflowSchedulerService
' from assembly 'System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35'.
at System.RuntimeTypeHandle._GetTypeByName(String name, Boolean
throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark&
stackMark, Boolean loadTypeFromPartialName)
at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean
throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark&
stackMark)
at System.RuntimeType.PrivateGetType(String typeName, Boolean
throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark&
stackMark)
at System.Type.GetType(String typeName, Boolean throwOnError)
at
System.Workflow.Runtime.WorkflowRuntime.AddServiceFromSettings(WorkflowRuntimeServiceElement serviceSettings)
at
System.Workflow.Runtime.WorkflowRuntime.PrivateInitialize(WorkflowRuntimeSection settings)
at System.Workflow.Runtime.WorkflowRuntime..ctor(String configSectionName)
at
System.Workflow.Activities.WorkflowWebService.get_CurrentWorkflowRuntime()
at System.Workflow.Activities.WorkflowWebService.Invoke(Type
interfaceType, String methodName, Boolean isActivation, Object[] parameters)
at SharedWorkflow.MathServiceWorkflow_WebService.DivideNumbers(Double
dividend, Double divisor) in
C:\Users\rdean\AppData\Local\Temp\k0ca55is.cs:line 0


The Web.Config looks like this:


<?xml version="1.0"?>
<configuration>

<configSections>
<section name="WorkflowRuntime"
type="System.Workflow.Runtime.Configuration.WorkflowRuntimeSection,
System.Workflow.Runtime, Version=3.0.00000.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" />
</configSections>

<WorkflowRuntime Name="WorkflowServiceContainer">
<Services>
<add
type="System.Workflow.Runtime.Hosting.ManualWorkflowSchedulerService
, System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35"
UseActiveTimers="true"/>

<!-- <add
type="System.Workflow.Runtime.Hosting.DefaultWorkflowCommitWorkBatchService
, System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35" /> -->

<add type="System.Workflow.Runtime.Hosting.SqlWorkflowPersistenceService
, System.Workflow.Runtime
, Version=3.0.0.0
, Culture=neutral
, PublicKeyToken=31bf3856ad364e35"
UnloadOnIdle="true"
LoadIntervalSeconds="5"
ConnectionString="Initial Catalog=WorkflowPersistance;
Data Source=SLCQCSQL;
Integrated Security=SSPI;"/>
</Services>
</WorkflowRuntime>

<appSettings/>

<connectionStrings/>

<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="false"/>
<!--
The <authentication> section enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<!--
The <customErrors> section enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm"/>
<error statusCode="404" redirect="FileNotFound.htm"/>
</customErrors>
-->

<httpModules>
<add type="System.Workflow.Runtime.Hosting.WorkflowWebHostingModule,
System.Workflow.Runtime, Version=3.0.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" name="WorkflowHost"/>
</httpModules>

</system.web>

</configuration>

Please let me know what I am doing wrong. All of the information I can find
confirm all of my settings for the config section for the
ManualWorkflowSchedulerService. Is there some set-up I am missing or some
setting that is not obvious?

Thanks,

Rob Dean
(e-mail address removed)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top