Win2000 Svr services/system unresponsive



We have a Win2000 sever SP4. On 8/12 we downloaded the following 6 KB
updates; KB893756, KB896423, KB896727, KB899587, KB899588, KB899591. We
didn't reboot the server until Monday 8/15. Upon reboot, we noticed nobody
can connect via RRAS. Upon further investigation we noted the following

* Control Panel will launch - but has no icons
* Windows Explorer cannot access the C:\Winnt subdirectory (no error
message, just no files/folders listed)
* Internet Explorer can access no websites (type in any URL and nothing is
displayed, ever. However we can ping Internet websites without any problem.)
* FTP from the command-line works, but not through IE.
* NO service can be controlled (not started, stopped, or paused). Attempting
to stop/start any service generates a message that the 'service is not
responding...' message
* Some applications will launch, others will not (no error, just no activity
once you click the icon to launch the app)
* Useful tools that DO work include Regedit, Regedt32, Event Viewer, CMD,
taskmgr and a few other system-level apps)
* Rebooting into 'safe mode' will get to the 'starting up windows' screen,
but never progress any further.

From a network perspective, users can still access shared resources like
files and printers - so they appear unaffected. We have researched this for
several hours browsing news groups, Google and other resources and have
found little useful info. This server is running McAffee enterprise v7.1
(updated definitions), and we have checked many registry entries to see if a
virus was causing this issue but no viral infections were found. This server
is not configured as a DNS server.

This is a Dell PowerEdge 4600 quad CPU w/1.0GB of memory. There is less than
5% CPU use and there is about 500MB of available RAM. The Event Viewer has
no clear indications of ANY component failure or service failure. The only
indications of any failures are in the 'system log' indicating that the
"30000 millisecond timeout expired waiting for a transaction response from
<insert service here>". This only occurs during bootup. If we look in the
'Services' list, we see that these services that 'timed out' during boot
appear to be 'started'.

The only changes that have been made is we rebooted from the KB installs
listed in the beginning of this post. Because we cannot get into Control
Panel, we cannot uninstall theses KB patches. We've attempted to launch the
add/remove programs using the .CPL file, but no GUI is produced. We've tried
booting into 'last known good' - but still no response. Running SFC /Scannow
finds several .DLL files that do not match original media - which makes
sense since this is a fully patched system

Before we perform any reinstall/recovery/SFC actions, does anyone have any
ideas of what to look at that we've missed?


UPDATE: After reading through some of the news postings in this (and other)
newsgroups, we found the "APC PBE Agent' service was 'starting' as indicated
in the Services listing. Using registry editor, we set the'startup type' for
this service to '3' (manual) and rebooted the server. This issue has been
resolved and the server is now responding normally:) Thanks in advance for
anyone who pondered our problem.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question