Win XP SP1 can't access a volume on a NetWare 3.12 server

  • Thread starter =?iso-8859-1?Q?Robert_Premu=BE?=
  • Start date


In a local network I have the following situation:
* MS Windows 2003 Server as a domain controller
(domain XYZ.local, short name: XYZ)
- TCP/IP network protocol, DHCP, DNS
* Novell NetWare 3.12 server (name: XYZ)
- IPX/SPX network protocol
* MS Windows XP Professional SP1 workstations (more
exactly: XP
Professional Ver. 5.1 Build 2600.xpsp2.030422-1633:
Service Pack 1)
- TCP/IP network protocol, IPX/SPX network protocol
- Client For Microsoft Networks (the Windows XP
- Client Service for NetWare (CSNW) (the Windows XP
- The workstations are added to the Windows 2003 domain.
- The user accounts for each user have the same username
and password
on both Windows 2003 domain and NetWare 3.12 server.
- The "Run Login Script" option is set in the CSNW options

In these circumstances, when users log into workstations,
they are not
able to open the XYZ\SYS volume on the NetWare server
although they
are attached to it.
Also the NetWare system login script (common for all
users) is not
executed during the login.
On the other side, the NetWare user login script
(individual for each
user) is executed during the login.
But the users are able to map a drive to the XYZ\SYS
volume, e.g. using
net use f: \\XZY\SYS
(this makes the problem really strange).

The same problem happens with the Windows 2000 Server and
But it does not happen if the short domain name (here XYZ)
different than the NetWare server name (here XYZ).

The problem is not with the NetWare permissions because if
the same
users log on a Win XP Pro. without SP1 installed or Win
2000 Pro. with
SP4 installed (which also exist in that Windows domain),
the problem
does not occur.

I tried to use Novell NetWare Client for Windows ver. 4.90
on the
workstations, but the problem remained.

So, I conclude that there is something broken in Windows
XP Service
Pack 1, which makes Windows XP Professional unable to
access a volume
on a NetWare 3.12 server if the name of the server is
equal to the
short name of the Windows domain the workstation belongs

It seems that currently the problem is not described in the
Microsoft Knowledge Base.

Any suggestions?

-- rpr. /Robert Premu¾/


on the ones that do not have a netware logon, in the tool bar bottom right corner, right click on the red N, netware logon, can you log on that way?

Bradford Brown

I finally found that Novell Client Version 4.83 SP1 works
perfectly despite all of the warnings on Novell's page
about using the latest Client software. Version 4.83 is no
longer available on Novell's web site. I do not know why,
but it is the only one that worked for my XP machine.
Version 4.9 all service packs failed miserably with errors
similar to yours.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question