Which cabs for Installing SQL Server Mobile and CF 2.0 with MSI onPDA?


T

Thomas Bandt

Hi,

I have built an Installer which interacts with Active Sync
for installing my own application as well as the CF and
SQL Server Mobile.

For that I am using ini-files, which is running fine on
Windows for Pocket PC 2003.

But not on Windows Mobile 2005!

Even if the installation process is succeeded (no errors
while installing) my app won't run. It then misses DLLs
for SQL Server Mobile. Remember: on 2003 it works fine.

So my question is: what cabs should I ship with? I am
currently shipping

sqlce30.phone.wce5.armv4i.CAB,
sqlce30.ppc.wce4.armv4.CAB,
sqlce30.ppc.wce5.armv4i.CAB,
sqlce30.wce5.armv4i.CAB,
sqlce30.wce5.mipsii.CAB,
sqlce30.wce5.mipsii_fp.CAB,
sqlce30.wce5.mipsiv.CAB,
sqlce30.wce5.mipsiv_fp.CAB,
sqlce30.wce5.sh4.CAB,
sqlce30.wce5.x86.CAB

Does anyone has an idea?
 
Ad

Advertisements

F

Fredrik Ree

Which WM 5.0 device are you testing on?

Do you get an error message when starting the app?

/Fredrik
 
T

Thomas Bandt

Fredrik said:
Which WM 5.0 device are you testing on?

Do you get an error message when starting the app?

/Fredrik

I am testing with a Pocket PC of a german manufacturer
and with the emulators shipping with Windows Mobile 5.0
Pocket PC SDK.

And yes, i get an error by starting the app:

""System.Data.SqlServerCe" not found "(in german ...)
 
F

Fredrik Ree

This also happened to me once on a WM 5.0 ARM 4 device, due to the fact
that I had forgotten to install sqlce30.wce5.armv4i.CAB.

Are you sure it gets installed?

/Fredrik
 
T

Thomas Bandt

Fredrik said:
This also happened to me once on a WM 5.0 ARM 4 device, due to the fact
that I had forgotten to install sqlce30.wce5.armv4i.CAB.

Are you sure it gets installed?

Not sure, but it is in the list of my ini file:

[CEAppManager]
Version = 1.0
Component = bla

[bla]
Description = SQL Server 2005 Mobile Beschreibung
CabFiles =
sqlce30.phone.wce5.armv4i.CAB,sqlce30.ppc.wce4.armv4.CAB,sqlce30.ppc.wce5.armv4i.CAB,sqlce30.wce5.armv4i.CAB,sqlce30.wce5.mipsii.CAB,sqlce30.wce5.mipsii_fp.CAB,sqlce30.wce5.mipsiv.CAB,sqlce30.wce5.mipsiv_fp.CAB,sqlce30.wce5.sh4.CAB,sqlce30.wce5.x86.CAB

And if I am right the ActiveSync installer selects the right cab
depending on operating system and processor type, right?
 
Ad

Advertisements

F

Fredrik Ree

Check for the dll file sqlceme30 in the windows directory of your device.

If it's not there, the SQL Server Mobile is somehow not deployed.
And if I am right the ActiveSync installer selects the right cab
depending on operating system and processor type, right?


That's what it's supposed to do, yes.

/Fredrik
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top