Vista Premium Install Doesn't take.



I am attempting to "upgrade" install Vista Premium (it's an academic version,
if that matters) on an XP-sp2 system, which otherwise runs fine. I have
installed all windows updates.

My setup:
Athlon 64 3800+ processor ~2.4gHz
Gigabyte GA-K8U-939 ATX motherboard
3 GB PC3200 DDR 400 RAM
ATI RADEON x1600 series AGP graphics card with 512mb video ram
230GB SATA Hard drive, recently defragged, with over 120GB free space

I have uninstalled norton antivirus and the vista upgrade advisor shows no

The install process gets as far as the final "Completing Installation"
phase, when I get the BSOD and a stop 0x000000EA error message, after which
the system reboots and reverts back to XP.

I understand this error message usually relates to a graphics hangup, so
I've tried the install with/without ATI catalyst software, using drivers 7.1
and 8.1 with no success.

My system appears to be "vista ready" but the install just doesn't take. Any
suggestions I haven't tried?


I should add that I'm upgrading from and to a 32 bit version of windows, and
my graphics card hasn't had any problems.

Again, any help or advice would be greatly appreciated.


After much frustration, I've figured out most of the problem.

Two issues were preventing Vista from installing:

First: The GA-K8U-939 motherboard and vista don't play nice initially. Even
after a full hard drive format and a clean vista install, I was still getting
the STOP 0x0000009c error when trying to boot from the Vista installation

Solution: The SATA setting needs to be switched from IDE to RAID in the bios
(even though I'm not installing raid drives) for the vista CD to load. Just
ignore the RAID setup screen when it flashes (don't press CTRL-A). Once the
cd loads, you need to manually install SATA drivers, either from a floppy,
flash drive or the drivers CD that came with the motherboard. On the CD, the
drivers you're looking for are under /chipset/winxp/sata/uli 5289 I believe,
or something to that effect.

Don't forget to switch the SATA setting back to IDE once you've finished
installing windows. It shouldn't be an issue again.

Second: My other problem was with the x1600 agp video card, which also
doesn't play nice with Vista. This is what caused the STOP 0x000000EA hangup
at the final installation.

Solution: The temporary solution has been to switch that card with an older
x800 agp card. This switch allowed Vista to finish installing and setup. Then
swap the x1600 card back in.

One note: after installing the pci-agp bridge drivers that came with the
motherboard, the video card ran and remained stable, but my system didn't
recognize it, even after installing catalyst drivers. (the drivers appear to
be installed, but the device manager doesn't recognize the card and instead
runs "VGA safe drivers").

For this reason, I recommend NOT installing those agp motherboard drivers
from the CD or Giga-byte's website. Uninstalling them caused my system to
BSOD and STOP 0x000000EA again. I'm going to try switching back to the x800,
getting it up and running on catalyst drivers, THEN swapping the x1600 back

Hope my frustration helps someone else out there. I'll probably update this
post when I get the x1600 up and running.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question