Vista local access, no internet




I installed Vista Business on a new computer (Asus P2) and it keeps loosing
the internet connection intermittently. Local access always works.

In the network are 3 computers, 2 Vista desktops, 1 XP Home which acts as a
file and printer server and a Draytek router behind a cable modem. The 2
Vista PC's are new and both have the same problem. When the XP machine was
the desktop PC this problem never occurred, and it still doesn't as the XP
machine always has a live internet connection (the cable provider is
wonderfully reliable). The machines are connected via a wired 100Mbps network.

But....Vista keeps loosing the internet connection, requiring manual
intervention to fix. When it occurs all seems normal (ip, gateway, dns, etc)
but IE, Firefox or Outlook cannot connect to any internet services/sites.

All machines are on DHCP from the Draytek router. Whenever the Vista machine
looses the connection the gateway IP is still there, so do all the other
network settings. Is also still has connection to the network I assigned to
it, so no 'unidentified' or 'unkown' network messages or anything of that
sort. It is a private network and Vista describes it as 'unmanaged' (btw.
anyone know what that actually means?).

So, what did I try to resolve this:
- Update the network driver to the latest one from Realtek (RTL8111C).
- Merge networks that where listed under Network and Sharing
Center->Customize->Merge or delete->etc
- Disabled the IP helper service
- Disabled IPv6, QoS and LLTP by removing checkboxes from the IPv6, Qos
Packet Scheduler, and both LLTP protocols in the network adapter properties
- Disabled the DHCP Broadcast flag as described in
- Disabled PnP IX, LLTD and IPsec Services

Anyone know a solution?


Oh, and I also disabled power management on the network adapter, tried normal
and Jumbo frames. Still no solution...

Frank Parmelee

I am not sure how much they charge, but my neighbor calls the Geek Squad
from our Best Buy store whenever she has problems. I thought about it and
then decided not to spend the money.

This machine is brand new and I figured to have no problems. This is so
aggravating and frustrating. For a brief moment I toyed with the idea of
putting Windows 7 on all our machines when it is available. I am not so sure
that is going to happen.



one month later and still no solution...
In the meantime I have grown so desperate that I swapped the cabling and the
router. But. to no avail. I know the router works (with Vista) but still the
computer disconnects leaving no other option but to reboot as Diagnose and
repair cannot fix the problem.

I am going crazy here and even thinking about downgrading to XP....



So I took the computer home with me and hooked it up to my local network.
Coulnd't find any problems until I left the computer alone for a while. When
I came back there it was: Red cross over the network icon!

After spitting through the eventlog and such I found that for some reason
the network adapter gets removed from the system. Here is the event
<Event xmlns="">
<Provider Name="PlugPlayManager" />
<EventID Qualifiers="49152">12</EventID>
<TimeCreated SystemTime="2009-04-17T10:17:47.000Z" />
<Security />
<Data>Realtek RTL8168C(P)/8111C(P) Family PCI-E GBE NIC</Data>

The textual message in the eventlog is in Dutch (why windows localizes this
is a complete mytery to me...feature creep, bloat?). Anyway:
Het apparaat Realtek RTL8168C(P)/8111C(P) Family PCI-E GBE NIC
(PCI\VEN_10EC&DEV_8168&SUBSYS_81AA1043&REV_02\4&2b0ed4dd&0&00E0) is uit het
systeem verdwenen zonder dat de verwijdering is voorbereid.

Roughly translated:
The device has unexpectedly been removed from the system.

This says to me it has something to do with the sleep/standby feature. I
already disabled power management on the adapter itself and upgraded to the
latest driver from Realtek: rtlh86.sys (, 139,50 kB (142.848
bytes), 20-1-2009 14:49)

The system is an Asus P2-P5945GC.
Anyone have any suggestions besides disabling sleep mode?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question