Vista knows my printer is there but will not print



I hooked up my laserjet 2100 printer through a usb/parallel converter cable.
Vista found it, loaded the driver, and every thing seemed ok. But everything
backs up in the print queu. When I try to restart, nothing happens. Even
the test page says it has been sent, but stays in the queu. And yes the
printer is on-line. Any ideas?

Hugh Wyn Griffith

.... laserjet 2100 printer through a usb/parallel converter cable.

I do support on Compuserve and experience with problems raised there
shows that USB to parallel coverters rarely work without problems, if
at all. Do you have a driver to install for the USB to parallel cable?
I know I do for my Nokia cell phone from USB to Serial -- and I
couldn't even get that working in XP ....

I had a LJ2100 working fine under XP using parallel connection but I'm
on a LJ2200d now and it works fine with USB.

Can you fit a PCI Parallel card and then have a parallel connection on
your PC or is it a laptop?

So far as troubleshooting is concerned you could try the various test
print options to make sure the printer is OK. There is one you can do
when you start up the printer on its own and there's one from the
Printer control "panel"

Then you could disconnect the printer, remove all traces of the printer
in Control Panel / Printers and in Device Manager if it's there (check
under the last USB section), reboot and then reconnect the cable and
printer and then let VISTA find it again

Oh yes -- one suggestion that HP makes is to disable printer spooling
and use print direct to printer.


Thanks, Hugh - These are all good ideas. I tried to install the drivers that
came with the cable but I got a message that the drivers did not understand
the operating system they were being installed on and stopped. I think these
drivers were written in the early days of XP and were really W2000 drivers.
I guess the next step is to buy a parallel card. My PC is a brand new
pavilion desktop with Vista loaded on it. I also tried to delete the printer
to start over and would not let me delete it. I appreciate the help. I hate
to replace the 2100. Even though it is old, it has not been used that much.
I think I have the original cartridge in it and it works fine.

Hugh Wyn Griffith

 I hate to replace the 2100.  Even though it is old, it has not been used that
much.  I think I have the original cartridge in it and it works fine.

It's a good printer. I'd still be using mine but it developed a fault out of
warranty and HP wanted $250 each (plus labor) for two systemboards that
diagnostics said had gone down.

So for about $100 more I got the LJ2200d with built in duplexing which I love.

It certainly sounds like a problem with the cable and its software -- any way to
check to see if it has a new driver? With the cable for my Nokia, which was not
a genuine $50 Nokia cable but a $10 clone I was able through Device Manager to
check the chip used within it and track down a driver specific to that chip,
which was not the same as the one in the Nokia cable, but although that did
enable XP to see that the phone was there I could not read any data of the SIM,
with or without the Nokia file manager.

I must remember to plug it in under VISTA and see if it recognizes it on its

Just check that you have a spare PCI slot in your Pavillion -- they sometimes
cut back on slots.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question