Vista, Firefox and UAC



I installed Firefox on my new laptop running Vista Home Premium. Every time
I open Firefox I get a UAC popup rthat requires authorization before I am
allowed to surf. In addition, whatever triggers the UAC popup has disabled
virtual scrolling and tap zones in my synaptics touchpad. (It works in
Firefox with UAC turned off, it works everywhere else - including in the IE
browser - even with UAC turned on)

I have tried a number of things to stop this behavior:

Uninstalling and reinstalling Firefox
Changing the appropriate registry key from "2" to "0" to control the popup
behavor (but not the trigger) [stopped popup, but didn't fix touchpad]
Granting my user account full privileged with respect to Mozilla [no effect]
Downloading the newest synaptics driver [no effect]
Using icacls to modify the integrity level [created a second popup]

Any suggestions? If I can't fix it, I'm running with UAC turned off, which
I'd ratehr not do. I'd tolerate the annoying popup, but not the loss of
virtual scrolling and touch zones on my touch pad.


Success! Finally. Total time (to date) to transfer 5 programs to my new
laptop and get them functional: 27 hours . It shouldn't be this hard.
Solving this problem accounts for well over half the time.

What finally worked was a third uninstall and reinstall, bare bones (no
optional reporting back to Mozilla , or anything else that was extra) run as
an administrator, and changing "Mozilla Firefox" to "Firefox" every time
"Mozilla Firefox" came up as a suggested name. Since each of these suggested
remedies had been individually tried before, I'm not sure what it was about
the combination finally fixed it - but I thought I'd share what worked in
case anyone else has this same problem.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question