Using LDIFDE to modify multiple attributes


M

Megan Kielman

Hey all, this is what by import file looks like:

dn: CN=Weldon\, William,OU=MSBRUIMFS10,OU=No Folder
Redirection,OU=Accounts,DC=corp,DC=weyer,DC=pri changetype: modify
replace: postOfficeBox
postOfficeBox: 577
replace: streetAddress
streetAddress: 289 South Pontotoc Road
-

This is the first time I have tried to change more then one attribute at a
time and I am getting a message that the token fails on line 7 which is the
'-'. Am I doing something wrong?
 
Ad

Advertisements

S

Simon Geary

You need to split the seperate modify operations with a hyphen and then an
empty line, you can't include all the changes at once like that. Try this,
and don't forget the blank line after each hyphen:

dn: CN=Weldon\, William,OU=MSBRUIMFS10,OU=No Folder
Redirection,OU=Accounts,DC=corp,DC=weyer,DC=pri
changetype: modify
replace: postOfficeBox
postOfficeBox: 577
-

dn: CN=Weldon\, William,OU=MSBRUIMFS10,OU=No Folder
Redirection,OU=Accounts,DC=corp,DC=weyer,DC=pri
changetype: modify
replace: streetAddress
streetAddress: 289 South Pontotoc Road
-
 
M

Megan Kielman

Thank you for the reply. One more problem. This is how my import file looks
now:

dn: CN=Massey\, Danny,OU=MSBRUIMFS10,OU=No Folder
Redirection,OU=Accounts,DC=corp,DC=weyer,DC=pri
changetype: modify
replace: postOfficeBox
postOfficeBox: 577
-

dn: CN=Massey\, Danny,OU=MSBRUIMFS10,OU=No Folder
Redirection,OU=Accounts,DC=corp,DC=weyer,DC=pri changetype: modify
replace: streetAddress
streetAddress: 289 South Pontotoc Road
-

But here is the new error message: Add error on line 1: No Such Attribute
The server side error is "The parameter is incorrect."

I am looking at line 1 but can't find anything wrong. please help
 
S

Simon Geary

I checked this syntax on my own DC and it worked fine. I would double check
everything as this should work. Do you have the correct user DN and the
appropriate permissions to make the changes?
 
Ad

Advertisements

M

Megan Kielman

Simon,
Turns out that I had too many spaces in my import file. It worked! Thanks
for the help!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top