USB Card reader has lost AUTORUN facility




Recently, my USB multi card reader has lost autorun functionality. Even the
'Autorun.exe' app did not fix.
For example when i inserted an SD card, a little window popped up asking
what app did I want to open the images with.

I presume the answer lies in the registry.

Can anyone help with restoring this functionality to my card reader.



First try Power Toy's Tweak UI from Microsoft:
Install, run and expand TweakUI as follows:
'My Computer', 'Auto Play', 'Types'
check the option to enable/disable this feature for removable drives.

More Detail on available features in Tweak UI:

If Tweak is no help the read this
(Warning: it's a little on the confusing side) ?

CD AutoRun basics

Autorun, What is it?



the Tweak UI did notwork. I found the
very confusing! Other solutions suggested chaging the values in
NoDriveTypeAutoRun to default values i.e. in XP , 149 (decimal) OR 128
(decimal) - neither of these worked.

In the end I found a solution.

I used the advice in this link
i.e. i deleted the registry entries as advised. However, this only worked
when coupled with the MS 'Autofix.exe' app.

After I deleted the registry keys, i ran Autofix.exe for the removable
drives in question. I then restarted the PC , clicked on 'My Computer/ X
drive/properties/autoplay/picture files/prompt/apply. When I the inserted
an SD/CF card, the Autoplay dialogue window was back offering the various

Thanks for your help.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question