Uninstalling SP4 Causes Blue screen



We updated some workstations 2 the latest fixes, including SP4. Apparently
there was a problem with one of the important apps we run on these machines
afterwards, so we were told to uninstall SP4. In the midst of that, we get
a message saying that some files couldn't be found and to put the Windows
2000 disk in. Here's where the fun starts. Apparently our win2k copy has
walked off, so we tried to bypass the error. BAD MISTAKE. Now it boots to
a blue screen saying that winsrv.dll could not be found at the specified
path. I have tried the repair procedure, using a disk from home, but NO
JOY. I have been able to boot using the Recovery console, and can see that
winsrv.dll exists in winnt\system32, and in the dllcache directory.

Does anyone have an idea what I can do, short of reformatting and


Dan King

Run a recovery installation. It will reinstall the core
system files and get the system operational again.

When choosing the install don't enter recovery mode where
it askes for the floppy disk, or the recovery prompt.
Instead continue with the install. When is discovers there
is already an installation there, you have an option for
repair the existing installation. It takes a while to run
the install again, and you will have to put in the license
code, but all your apps will be there, and remain
functional. It will also be running at the service pack
level the install disk has.

I have performed this several times when I had users
shutdown their systems midway through an automatic SP4
deployment. I know it works for going up an SP level, I
would imagine it should work going down a level as well.

Good luck

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question