Type Conversion Failure importing number as text


T

tonyv

I am trying to import a file that has a column which contains a long
number. the numbe is a tracking number and in the vast majorty of
records it is puresly numeric. but in every 100 records there are a
few that are alpha/numeric. Access always chokes on the couple alpha/
numeric entries despite all muy attempt to get around the error.

I have tried importing as a CSV and XLS. I have used an Import
Specification that has the field type set to text. I have imported to
an existing table where the field type is text and size of 255, I have
tried importing to a new table with and without the import spec. In
all cases I get Type Conversion Failure on those few records. The rest
of the record imports but it blanks out those fields. In the case of
importing to an existing table, afterthe import failure I can type the
value directly into field so I know that data type is acceptable.

Here are some sample vlaues to illiustrate. The 4th is alpha/numeric
and won't import.

415A042966
4150848810
4052318949
415A042966
4150849521
4150849522

Any ideas?

Tony
 
Ad

Advertisements

T

tonyv

Forget it. I found that some but not all of the columns used quotes as
a text qualifier and I hadn't set that option in the Import spec when
importing from a CSV file. Once I did that it corrected the problem.

thanks for reading.
tony
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top