Troubleshooting RIS: why doesnt $oem$\$1 work


F

folkvord

Hi!

I've installed and configured RIS on a Windows 2003 server, and I've
created two images (the default copied from my winxp select-cd, and one
created with riprep on a pc install with complete office and so on).

The riprep-image seemed to work fine untill I tried using it on a pc
with a different NIC. At first the client wouldn't even boot from the
RIS-server, but following the instructions from the manufacturer I was
able to fix that.

The manufacturer also provided info on how to deploy the drivers with
the image, so that the client can find and install the neccessary
drivers from after the install.

I've followed these instructions, and checked with the docs from
Microsoft over and over again, but this is still not working.

If I've understood this correctly, anything i put in the directory
<image>\$oem$\$1 should be copied to the first harddrive (c: in my
setup) on the client, no matter what. Is this correct ?
(I can't find any of the contents of the $1 directory on my c:\ after
the install)

Furthermore, when the client boots after the install and find new
hardware, it should locate the drivers i've copied using the
$$-directory, if these directories are present in "OEMPnPDriversPath".
Is this correct as well ?

Here is my current setup. Can anyone see what I am doing wrong here ?

Image is located at:

d:\RemoteInstall\Setup\Norwegian\Images\WINXP_SELECTCD

where I have the two directories

i386
$oem$

the structure for the $oem$ directory is:

D:\RemoteInstall\Setup\Norwegian\Images\WINXP_SELECTCD\$OEM$\$1\Drivers\network

My ristndrd.sif contains the following settings in the [unattended]
section:

[Unattended]
UnattendMode=FullUnattended
DriverSigningPolicy = Ignore
OEMPreinstall=Yes
OEMPnPDriversPath = \Drivers\display;\Drivers\network
FileSystem = LeaveAlone
ExtendOEMPartition = 0
TargetPath = \WINDOWS
OemSkipEula = yes
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1


----------------


I would appreciate any help, since I am kind of stuck now :)

Thanx,
Oystein
 
Ad

Advertisements

?

?ystein Folkvord

If I've understood this correctly, anything i put in the directory
<image>\$oem$\$1 should be copied to the first harddrive (c: in my
setup) on the client, no matter what. Is this correct ?
(I can't find any of the contents of the $1 directory on my c:\ after
the install)

Furthermore, when the client boots after the install and find new
hardware, it should locate the drivers i've copied using the
$$-directory, if these directories are present in "OEMPnPDriversPath".
Is this correct as well ?

Here is my current setup. Can anyone see what I am doing wrong here ?

Image is located at:

d:\RemoteInstall\Setup\Norwegian\Images\WINXP_SELECTCD

where I have the two directories

i386
$oem$

the structure for the $oem$ directory is:

D:\RemoteInstall\Setup\Norwegian\Images\WINXP_SELECTCD\$OEM$\$1\Drivers\network

Hi!

I've just tried to install the image based on the select-cd, and then
the files are copied onto my hard-drive. If I try to install from the
image created with riprep then I have no luck.

So this seems to work as intended, at least for the first image I've
created. Is there any setting in the sif-file that can prevent the
copying of files. I would like this to work for my customized images
as well, but I can't figure out why it's not working for both of the
images.

Ø
 
Ad

Advertisements

G

Guest

If the RIS image was created with RIPREP, you must perform these steps on
both the RIPREP image and the RISETUP image that corresponds to the RIPREP
image.

Just a kind note that you should also put driver files to both i386 folder
and $OEM$\$1\Drivers\network folder on the following two images:

d:\RemoteInstall\Setup\Norwegian\Images\WINXP_SELECTCD (Assume this is
RIPREP image)

d:\RemoteInstall\Setup\Norwegian\Images\WINXP_RISETUP (Assume this is the
CD-ROM based image)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top