Symbols not appearing correctly


G

Guest

When I type symbols such as £ into an HTML document in Normal View, it
appears correctly in HTML view, but in preview and the published page it
appears as ?

I have found that by changing my browser settin using, Tooll, Internet
Options, Accessability and chen tick the cehck box for ignore fonts on web
pages, that they display correctly on the Preview page and the web page.

How can I ensure that everyone viewing the web page sees the symbols
correctly and not as a question mark?
 
Ad

Advertisements

G

Guest

This is how it apears in the HTML view - is that what you mean?
----------------------------------------
2 numbers cost £0.05 5
numbers cost £0.50 8
numbers cost £1.40<br>
3 numbers cost £0.15 6
numbers cost £0.75 9
numbers cost £1.80<br>
 
G

Guest

Sorry the computer must have took my code and translated it. If you go to
the page I reference and look for pound you will see the code for it:
& p o u n d ;
 
G

Guest

That certainly works. Just wondering if there is an easier way, especially if
the £ sign is used often. Also applies to quote marks, hyphens etc. when I
paste a page from MS Word.
 
Ad

Advertisements

G

Guest

I was on US/Western, but changing to Multilingual (UTF8) makes no difference.
Is there likely to be something in the style of the web site that is doing
this?
 
R

Ronx

Using UTF-8 usually cures this problem, but only if your server does not
change the charset setting with its http headers.
Your pages should have a meta tag that sets the charset, as well as
FrontPage being set to encode the pages as UTF-8. Also each page will
have to be opened and saved with the new charset encoding.

The meta tag will be similar to:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

To check the server's headers either post a link to a page here, or use
the Web Developer addon in FireFox and look at a page on the server.
--
Ron Symonds - Microsoft MVP (FrontPage)
Reply only to group - emails will be deleted unread.

http://www.rxs-enterprises.org/fp
 
G

Guest

I took over running the website I had problems with.

Between the responses received, it pointed me to a charset problem. I
checked the help in FrontPage and found out

FrontPage uses a web's default page encoding to help determine the language
for new pages. This encoding is then used to determine how a page is saved.
You can change a web's default page encoding to a different one. For example,
if you prefer Unicode, change the default page encoding to Multilingual
(UTF-8).

On the Tools menu, click Web Settings, and then click the Language tab.
In the Default page encoding box, select the default page encoding for the
current web.

I had been using pages created by the previous operator, and found that the
setting was default, but by changing to US/Westeren or Multilingual UTF-8,
the sympols all appear correctly.

The default charset is
document.write('<meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1">');
which I now need to find out how to change, however any new pages I make
from scratch follow my keyboard and work correctly.

Many thanks your assistance.
 
Ad

Advertisements

G

Guest

I took over running the website I had problems with.

Between the responses received, it pointed me to a charset problem. I
checked the help in FrontPage and found out

FrontPage uses a web's default page encoding to help determine the language
for new pages. This encoding is then used to determine how a page is saved.
You can change a web's default page encoding to a different one. For example,
if you prefer Unicode, change the default page encoding to Multilingual
(UTF-8).

On the Tools menu, click Web Settings, and then click the Language tab.
In the Default page encoding box, select the default page encoding for the
current web.

I had been using pages created by the previous operator, and found that the
setting was default, but by changing to US/Westeren or Multilingual UTF-8,
the sympols all appear correctly.

The default charset is
document.write('<meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1">');
which I now need to find out how to change, however any new pages I make
from scratch follow my keyboard and work correctly.

Many thanks your assistance.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top