Strange IIS connection error


J

John Haycock

Hi all
While developing a web app in visual interdev.net 2003
i get this error when i try to run the app:

There are too many people accessing the Web site at this time.

--------------------------------------------------------------------------

Please try the following:

a.. Click the Refresh button, or try again later.

b.. Open the localhost home page, and then look for links to the
information you want.
HTTP 403.9 - Access Forbidden: Too many users are connected
Internet Information Services

The problem is intermitent. I'm using IIS 5.1 and ASP 1.1

What can cause this? It's never happened to me before in the last 3 years

Thanks in advance

John
 
Ad

Advertisements

K

Kevin Spencer

What can cause this? It's never happened to me before in the last 3 years

It is caused by too many users being connected to Internet Information
Services.

--
HTH,

Kevin Spencer
Microsoft MVP
Chicken Salad Surgery

What You Seek Is What You Get.
 
J

John Haycock

Kevin Spencer said:
It is caused by too many users being connected to Internet Information
Services.

Hi Kevin

That's the thing its on my development machine at home. Theres noone
connected to it but me?
 
J

John Haycock

Juan T. Llibre said:
One user can generate several connections.
Yes but I don't see how by just running a web app. I always close
connections in the code and it's the first time it's happened in over 3
years. it's just a basic site with some web forms and fckeditor embedded in
some of the pages
 
J

Juan T. Llibre

re:
I always close connections in the code

The problem is not data access connections. You're not running out of those.
It's http connections.

Windows XP is limited to 10 connections...of all types, both incoming and outgoing.

Run this little test and you'll probably be surprised
at the number of connections you actually have open :

Open a command window ( Start, Run, cmd ) and issue the command :

netstat -a

Make sure you're sitting down when you do that.
I'll bet you didn't know you had so many active connections open.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
 
Ad

Advertisements

J

John Haycock

Juan T. Llibre said:
re:

The problem is not data access connections. You're not running out of
those.
It's http connections.

Windows XP is limited to 10 connections...of all types, both incoming and
outgoing.

Run this little test and you'll probably be surprised
at the number of connections you actually have open :

Open a command window ( Start, Run, cmd ) and issue the command :

netstat -a

Make sure you're sitting down when you do that.
I'll bet you didn't know you had so many active connections open.

Hey Juan you are right that is a shock. But why has localhost got so many
connections open with lots of different ports? Am I being hacked or what? As
I say this is the first time in three years I've got that error so I'm
assuming I have more connections now for some reason
 
J

Juan T. Llibre

re:
Hey Juan you are right that is a shock.

heh, heh... I knew it'd be a surprise. :)

re:
Am I being hacked or what?

Nope. That's just the way things work.

re:
But why has localhost got so many connections open with lots of different ports?

Your server ( IIS 5.1 ) is listening on several ports and your active connections
( browser requests from IIS ) stay alive for the default time-to-live configured for Windows XP.

You shouldn't mess with the default time-to-live, but you can tweak
Windows XP so you can have more connections ( although you aren't supposed to ).

See :
http://www.theeldergeek.com/increase_internet_download_connections.htm
and
http://www.helpwithwindows.com/WindowsXP/tune-120.html

They have the same instructions...

Note : Doing what those sites recommend implies editing the Windows Registry.

What I am telling you is not a recommendation to go ahead and hack
the Windows Registry and, if you do it, you do it at your own risk.

At the very least, backup your registry so you can restore it later in case of an "accident".
After those required disclaimers, feel free to proceed at your own risk.

:)




Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
 
J

John Haycock

Thanks for the help Juan. If it keeps happening as reguarly as it is doing
lately I might just give it a tweak :)
 
Ad

Advertisements

Joined
Nov 23, 2015
Messages
2
Reaction score
0
"Juan T. Llibre" <(e-mail address removed)> wrote in message
news:%(e-mail address removed)...
> re:
>> I always close connections in the code

>
> The problem is not data access connections. You're not running out of
> those.
> It's http connections.
>
> Windows XP is limited to 10 connections...of all types, both incoming and
> outgoing.
>
> Run this little test and you'll probably be surprised
> at the number of connections you actually have open :
>
> Open a command window ( Start, Run, cmd ) and issue the command :
>
> netstat -a
>
> Make sure you're sitting down when you do that.
> I'll bet you didn't know you had so many active connections open.


Hey Juan you are right that is a shock. But why has localhost got so many
connections open with lots of different ports? Am I being hacked or what? As
I say this is the first time in three years I've got that error so I'm
assuming I have more connections now for some reason

How did you terminate the connections?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top