Shared printer problem. XP to Vista printing.


S

Steve

I have a Vista computer and an XP computer. Both are on a domain.
I have an HP Laserjet 1018 printer attached and installed locally on
the Vista computer.
The printer is shared and is added to the XP computer.

When printing from XP to the laserjet printer on Vista it acts like it
goes..no errors but nothing comes out.
However, if you restart the print spooler then the jobs start
printing.
The printer works fine when printing from the Vista machine but not
when you try to print from other computers on the network.
Anyone know how to resolve this without having to restart the print
spooler all the time?

Drivers have been reinstalled and that does not help.
I also tried removing the printer. Re-adding it. Sharing it again and
re-adding it to other hosts on the network....same issue.
 
Ad

Advertisements

A

Alan Morris [MSFT]

this sounds like a security issue.

When the spooler is started, any pending jobs are scheduled with the spooler
security token rather than the users.

I do not see an inbox driver for the 1018 so I assume you got the driver
from HP.

The first thing would be contact HP and find out if the driver is creating
temp files somewhere but this will most likely take too long and might not
be fruitful.

So...

check the system event log for print errors.

Verify \windows\system32\spool\printers has write access for the Everyone
group

You can also try opening %temp% (normally \windows\temp ) for Everyone
access but change this back if that does allow the printer to work


download filemon and regmon and find out if the driver is attempting to
create file somewhere that is failing.



--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.
 
G

Greg DC

Hope you don't mind if I piggy-back on this.
I have a similar problem but going the other way
I have a XP SP2 computer with a X1185 attached to it.
I have a Vista business comuter. Both are on a router and Vista can "see"
the XP in My Network. I can open the XP and see the printer, X1185.
I have added a network printer to the Vista "successfully". But when I
print to the network printer the spool file on the Vista shows it ready to
go, but the XP does not show it in the spool and nothing prints.

Any Ideas would be appreciated!!
 
Ad

Advertisements

S

Subramanian

Hi,

Have you solved this problem, Bcoz i am also face this problem, If you
solved, mail me "how you solved?" this problem
My ID Is (e-mail address removed)


Regards,
Subramanian.J
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top