Shared Printer on XP worked once, but no more


G

Guest

Through great trickery I was able to connect Vista laptop to shared printer
hosted on Windows XP. Printing once worked. Now after both computers have
rebooted I can no longer use the printer from Vista.

Windows XP Pro connected to Canon S9000 USB printer.
Windows Vista Home Premium laptop, wireless.
Both computers in same workgroup.
File sharing works - Vista laptop can use shared folders on the XP host.
As everryone here reports, you can seeminlgy install network printer on
Vista, but then you get a failure. So instead I followd these steps:

1. net use lpt1 \\xpmachine\s9000 /persistent:yes
2. On Vista I Add New Printer to LPT1, I am able to select Canon S9000 (I
guess the drivers are already on Vista?).
3. Print test page and more! Yes, it works!
4. Weeks later (I don't print often!) it doesn't work.
4a. Vista does not seem to be able to establish the network connecction to
the printer, but of course file sharing is A-OK.
4b. On Windows XP I see that there are two instances of S9000 - the main one
that was installed on XP and another that claims to be from my Vista machine;
the port for this printer instance is "Inactive TS001". What the hell??

OK, that about covers it. I've been all over this forum and not found an
answer. Anyone out there been down this road?
 
Ad

Advertisements

G

Guest

Oh! I CAN print a test page. But I can't print anything else - all other
attempts just generate an error in the print queue. I also can't get the
printer status - that too shows an error in the print queue.
 
G

Guest

Glenn Nelson,

I'm sorry you're experiencing trouble. Since you can print a test page,
then it sounds less like a networking issue, and more like a driver issue.
Try checking for driver updates.
 
Ad

Advertisements

G

Guest

Well, isn't this disappointing:
1. 3 weeks later I get an automatic notice from this forum saying someone
has responded to my question. But no one has! One strike against Microsoft (a
company that I have no quarrel with).

2. No replies regarding such a serious and bizarre problem. I know there are
other questions about this vexing issue, but I haven't seen any others that
said "Got it working and then it quit".

Fortunately Dell tech support was up to the challenge. The problem was that
my remote printer never actually worked from this Vista laptop - only the
test page printed and the test page is apparently printed by a different
route than actually printing a page from say a browser! The key step that I
miseed was that I had to make the printer ON THE LAPTOP a shared printer,
even though no one is using it except for this laptop. Very weird.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top