Running a VBS script



When I try to run a vbs script using cscript in a dos prompt, I receive the
following error:
C:\Documents and Settings\Rick\My Documents\My Scripts>cscript test.vbs
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

Input Error: There is no script engine for file extension ".vbs".

I get the same error if I run wscript from the run dialog box.

Any ideas? No help for the error in TechNet

Wesley Vogel

What happens if you double click the .vbs file?

Windows® XP File Association Fixes
Copyright 2003 - Doug Knox

Read the instructions.

VBS File Association Fix (Restores default associations for VBS files)

Hope this helps. Let us know.

MS-MVP Windows Shell/User



The same error except in a Windows dialog box. I actually had to set the
association manually on the .vbs file.

Those registry entries fixed the problem tho.

TNX for the assist.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question