rundll32 printer command runs...but no printer!



I run a very simple STARTUP script through win2000 AD on XP clients.
rundll32 printui,PrintUIEntry /in /n \\server\printer

it should install a printer. It definitely runs and the 'installing
printer' box appears and then disappears. When I log in no printers have been

If I run the script when logged in it works fine. It has worked fine with
win2000 clients for years

Nothing in event viewer....any ideas?

Ryan Hanisco


This sounds like a permissions error... the account that is trying to add
the printer does not have the rights to do this, where yours does. You can
try running this as a computer startup script to use the computer
credentials, but then you'll lose the ability to map based on user group

Otherwise, I would suggest using the Sanur.exe utility to specify user
account and password to the command. This is like a RunAs but allows the
specification of a password. This is a free utility, gotten at:

As to the add method, you might look at using con2prt, a windows utility
that works well for the adding and removal of printers.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question