Rules and Alerts in MS Office 2007


B

Barbara

I have created 22 different rules and they all start with:
"Where my name is in the To or Cc box"
and from "from people or distribution list"
and "sent to people or distribution list"
and "move it to the _____ folder"

all my folders are labeled "Inbox - 01, Inbox - 02, Inbox - 03, and so on"
They were all working until recently, I say within the last few weeks. I
have had MS Office 2007 for over five months.

Just this week I went in and deleted all my rules and re-created them and
they are still not working.
I have two "Apply changes to this folder" and I have copied the rules to
both.
 
Ad

Advertisements

B

Brian Tillman [MVP - Outlook]

I have created 22 different rules and they all start with:
"Where my name is in the To or Cc box"
and from "from people or distribution list"
and "sent to people or distribution list"
and "move it to the _____ folder"

all my folders are labeled "Inbox - 01, Inbox - 02, Inbox - 03, and so on"
They were all working until recently, I say within the last few weeks. I
have had MS Office 2007 for over five months.

So what did you change between when they worked and "until recently"?
 
B

Barbara

Brian - I have not done anything. The emails just quit going into their
respectful folders. I am not the only one at my college that this having
this issue. Our IT people said they have not done anything to the server.
Someone wrote that a recent MS update for Outlook 2007 was sent out
(KB952142) and he removed it from his PC and his rules started to work again.
The was posted by on March 21 under the general questions. I'm on a network
and do not have access to remove or install items on my PC.
 
B

Brian Tillman [MVP - Outlook]

Brian - I have not done anything. The emails just quit going into their
respectful folders. I am not the only one at my college that this having
this issue. Our IT people said they have not done anything to the server.
Someone wrote that a recent MS update for Outlook 2007 was sent out
(KB952142) and he removed it from his PC and his rules started to work
again.
The was posted by on March 21 under the general questions. I'm on a network
and do not have access to remove or install items on my PC.

I don't know if this will help, but it's worth a try. Export your rules using
the Rules Wizard. Then close Outlook and restart it with the /cleanrules
command switch (Start>Run>outlook.exe /cleanrules) (notice the space after
"exe"). Import the rules you saved and see if they operate.
 
F

F.H. Muffman

Brian - I have not done anything. The emails just quit going into
I don't know if this will help, but it's worth a try. Export your
rules using the Rules Wizard. Then close Outlook and restart it with
the /cleanrules command switch (Start>Run>outlook.exe /cleanrules)
(notice the space after "exe"). Import the rules you saved and see if
they operate.

And if /cleanrules doesn't work, I'd think about deleting everything but
1 rule and testing that rule alone.

If it works, do the /cleanrules, import the rules, delete all but two.

Test both.

And keep doing that until the rules suddenly fail. Then, look at that last
rule you've added and see what it does.
 
B

Barbara

Hi Brian - F.H. - I exported all my rules and then did the "cleanrules".
When I opened the Rules and Alerts under "Apply Changes to this folder" the
second folder has this in it "clear categories on mail (recommended)". I
have checked the box, ran the "run rule" and then deleted this item. I then
proceeded to import my rules, but that did not work, so I re-entered all my
rules and for the most part that did work. I am now having trouble with some
rules that are sent to distribution lists where I am a part of that list. Do
I want or need all of the following to get the rules to work

"Where my name is in the To or Cc box"
and from "from people or distribution list"
and "sent to people or distribution list"
and "move it to the _____ folder"

I have removed the "Where my name is in the To or Cc box" or do I need to
leave that in? I have email rules set up with someone who is from the "from
people" and I am in the "distribution list" but the email not moving to the
specific folder.

Do I need to add to all my rules "on this machine only"?
 
Ad

Advertisements

F

F.H. Muffman

I am now having trouble with some rules that are sent to
distribution lists where I am a part of that list. Do I want or need
all of the following to get the rules to work

"Where my name is in the To or Cc box" and from "from people or
distribution list" and "sent to people or distribution list" and "move
it to the _____ folder"

"from "from people or distribution list"" is *very* dangerous because
it usually doesn't do what you think it is going to do.

It will look at that DL and use the members of that DL to determine
if the rule should be applied to the message.

So, if Joe, Mary and Tom are on that DL, and they send you a message,
that rule would try to run against it.

If all you want is to have the rule affect messages sent to a distribution
list, that's all that should be on the rule.

If you want the rule to affect messages that are sent to a distribution
list AND are from people on that distribution list, then you need to have
sent to and from that distribution list.

If you want the rule to affect messages that are sent to a distribution list
AND are from people on that distribution list AND you are on the mail as well
on either the To or CC line, then all three need to be there.

I have removed the "Where my name is in the To or Cc box" or do I need
to leave that in? I have email rules set up with someone who is from
the "from people" and I am in the "distribution list" but the email
not moving to the specific folder.

Do I need to add to all my rules "on this machine only"?

Uh, only if you want it to only run on this machine or you add actions that
require Outlook to be running.
 
B

Barbara

Good Morning F.H.
I know have all my rules working again. I realized that I needed to create
separate rules for distribution lists and have them connected to the folder
that I wanted.

Thank you and Brian for all your help with this issue.
 
B

Barbara

Hi F.H.
My rules and alerts have stopped working again. This time I noticed that
when I had turned on my "Out-of-Office Assistant" and I did not create any
rules in this area, that when I got back my rules were not working again.
Why do I need to set up rules in my "Out-of-Office Assistant" if they are
already in my main outlook setup? Why is the setup different between the two
sets of rules?
 
Ad

Advertisements

F

F.H. Muffman

My rules and alerts have stopped working again. This time I noticed
that when I had turned on my "Out-of-Office Assistant" and I did not create
any rules in this area, that when I got back my rules were not working
again.
Why do I need to set up rules in my "Out-of-Office Assistant" if they
are already in my main outlook setup? Why is the setup different between
the two sets of rules?

The rules that you add to the Out of Office assistant are only run when OOF
is turned on. The only reason why turning on OOF would make rules not function
is if you had a catch-all type rule that basically said 'stop processing
more rules'.

If your rules aren't working right now, then you need to start with the basics.

Do they run individually if you do a run rules now.
Have you rebooted the system.
Have you created any new rules lately.
Try unchecking all but one that you can test and see if it works alone.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top