RRAS service won't start


Alex Saager


after trying to setup routing and remote access it gets to
the end of the wizard and gets the following error:

an error occured wilst trying to start the RRAS service on

these enteries are in the event log

1. The Routing and Remote Access service terminated with
service-specific error 2.

2. Unable to load C:\WINNT\System32\iprtrmgr.dll.

i have checked this file it does exist and i even tried
coping it from another machine.)

still doesnt work

any ideas anyone?

Sharoon Shetty K [MSFT]

Check if the following key exist
and it has this entry
1) DllPath

Verify if the path of the Iprtrmgr.dll in your machine is the same.

Ensure that "Remote Registry Service" is running.


I have checked this, the paths are the same all the
registry enteries are the same, but still i can't start
the service.

any other ideas would be a great help?


alex saager

Srivatsan [MSFT]

Can you enable tracing on the server, start 'Routing and Remote Access'
service and send iproutermanager.log?

For enabling tracing, you can use the following command: C:\>netsh ras set
tracing * enable

The log files will be created under %windir%\tracing

you can disable tracing using the following command: C:\>netsh ras set
tracing * disable

Srivatsan [MSFT]

Also check whether the file 'wararp.sys' exists under

Alex Saager

Still i have tried all of these solutions but i still
cannot get the RRAS service to start.

i did start the tracing, what will this do though?

any other idea's would be appriciated.


Alex Saager

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question