Robocopy sets attributes on destination folder to system and hidde




I am trying to copy a file from one Vista system to another. I have created
a mapped drive on one box.

I issue the command

robocopy c:\ y:\images\ 1.wim I have also tried
robocopy c: y:\images 1.wim

Each time when robocopy completes the directory attribbutes on the second
system \images is set to system and hidden.

If I issue the same command to the same system (i.e., robocopy c:\ c:\temp
1.wim) the attributes on c:\temp are not set to system and hidden.

Is there some way to fix this or what am I doing wrong?




Synapse Syndrome

glennpsion said:
Did you ever get a reply?
I have found if the destination folder exists, then things work.
If it doesn't then the destination folder is created as a hidden folder
AND you cannot remove it as it is made as a 'system folder'.
I have got aroung this my using mkdir command before running the
robocopy command..............but surely robocopy should have an answer
to this (a switch?) or is this a bug?

Nobody in the newsgroup knows what you are talking about as you didn't quote
what you were replying to. Most people here are not using the forum that
you are using.

Anyway, what switches are you using? I have never seen behaviour as you
describe with Robocopy, although I do not use /COPYALL.


Synapse Syndrome

glennpsion said:
unbelievable. I just spent 10 mintue typing a reply into the box, go to
send, and it says it
has logged me out.............mail totally lost. Great...........!
I'll start again, this time cutting and pasting from a notepad file.

............"Nobody in the newsgroup knows what you are talking about
as you didn't quote
what you were replying to"..............if it is that difficult to use
the web site no
wonder very few people use it. I saw the message, I pressed reply.
Anyway, on to the problem:
I am actually using XP, but I understand from searches on the Web that
all this is also a
VISTA problem. This problem definitely exists:
'Robocopy and Hidden Files : Robocopy'
'Robocopy creates hidden directorys in win xp'
'Destination Folder hidden/invisible after using xcopy or robocopy -
Neowin Forums' (
The script I am using is:
robocopy F: "M:\290_MOB1_BU_D_Media" *.* /MIR /X /FP /V /XD "_RESTORE"
"System Volume Information" /R:1 /W:1 /TEE
If the destination drive is empty and robocopy has to create the
folder, then the folder is not only created as a hidden folder, but
created as a system folder, so th hidden attribute cannot be undone.
I get around this at the moment by putting the following script before
the robo script:
mkdir "M:\290_MOB1_BU_D_Media"
Everything then works ok and the folder is not hidden.
If the folder already exist, the command effictively gets ignored.
This has to be a bug.
If not AT THE VERY LEAST the documentation should explain why this
behaviour is so.

That is weird, and not something that I have had happen to me. What version
of Robocopy are you using? I use XP026 on XP, which is a newer version than
the one that comes in the Windows Server 2003 Resource Kit. One of the
links you gave suggests that this is not a problem in later versions of
Robocopy, like the Vista version.

Does this also happen with the /B switch, for Backup mode?

You can always use..

ATTRIB -h - s <folder name> get rid of those attributes. If you use the command without any name,
it should be applied to all folders and files in the current directory.




Synapse Syndrome

glennpsion said:
I am using an older version.
I can't even remember where I got it now.

Perhaps it was on the Windows XP CD.

Perhaps I need to get the newer version. Any idea where you can down
load it?

Perhaps setting the attribute will help, but creating the directory
equally works................ both is one command too many.

I haven't tried the /B switch.

I'll put this down as a bug which probably got fixed. I would need to
find an official XP026 and see what 'bugs' were fixed in there and if
this was one of them.

XP026 is the latest version that works correctly in XP, as far as I know.
The Vista RTM or SP1 versions do not work in XP. It's pretty stupid that
they still distribute XP010 in the Windows Server 2003 Resource Kit, as it
also has other bugs, like not copying over the correct folder timestamps
when told to do so.

The only way to get XP026, as far as I know, is to install the Robocopy GUI.
When you do that, XP026 gets added to your system32 folder.

Alternatively you can email me at the address in the headers (remove
spamtrap) and I will send it to you.

Post back if it does solve your problem.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Task Schduler settings 3
robocopy error 5
Robocopy 9
How to remove hidden directories 1
Windows Vista Robocopy 0
robocopy Version XP026 errorlevel not set 1
SyncToy vs RoboCopy 3
Robocopy quotation marks erro 3