Repeat formula within a cell

  • Thread starter HÃ¥vard Spaniland
  • Start date

H

HÃ¥vard Spaniland

Please help !!

I need a simple way to repeat some parts of a forula within a cell.

We are selling products which are priced pr millimeter, and we calculate
totale value of goods in stock. The formula collect mm price from one
sheet--> mulitiply with actual width-->multiply with quantity of each width.

Example of structue

10 20 30 40 45 48 Total value
2 546 321 21 654 546 325.213

The actual formula I currently use:
=((Priser!E8*$B$7)*$B11)+((Priser!E8*$C$7)*$C11)+((Priser!E8*$D$7)*$D11)+((Priser!E8*$E$7)*$E11)+((Priser!E8*$F$7)*$F11)+((Priser!E8*$G$7)*$G11)+((Priser!E8*$H$7)*$H11)+((Priser!E8*$I$7)*$I11)+((Priser!E8*$J$7)*$J11)+((Priser!E8*$K$7)*$K11)+((Priser!E8*$L$7)*$L11)+((Priser!E8*$M$7)*$M11)+((Priser!E8*$N$7)*$N11)+((Priser!E8*$O$7)*$O11)+((Priser!E8*$P$7)*$P11)+((Priser!E8*$Q$7)*$Q11)+((Priser!E8*$R$7)*$R11)+((Priser!E8*$S$7)*$S11)+((Priser!E8*$T$7)*$T11)+((Priser!E8*$U$7)*$U11)

The basic formula is ((Priser!E8*$U$7)*$U11) but copied to get all cells.

Please help me find a solution for this formula, and simplify my world....

Best regards
 
Ad

Advertisements

B

Bob Phillips

Not sure what you want, but your formula can be simplified

=SUMPRODUCT($B$7:$U$7*E8*$B11)

--
---
HTH

Bob


(there's no email, no snail mail, but somewhere should be gmail in my addy)
 
B

Bob Phillips

Hi Håvard,


How about this

=SUMPRODUCT($B$1:$U$1,$B2:$U2)*Priser!B2

--
---
HTH

Bob


(there's no email, no snail mail, but somewhere should be gmail in my addy)
 
H

HÃ¥vard Spaniland

Thanks once a again Bob,

You're my new super-hero.

I only need to change some minor things. I use a Norwegian version,
therefore the name was incorrect.

The 100% working code here:

=SUMMERPRODUKT(($B$1:$U$1);($B2:$U2))*Priser!B2
 
Ad

Advertisements

B

Bob Phillips

Thanks Håvard, I will don my cape <g>.

I had assumed you were using Norwegian version of Excel, and I thought about
translating it, but as you had posted in English I thought you were
comfortable with this aspect.

By the way, some of those brackets are superfluous

=SUMMERPRODUKT($B$1:$U$1;$B2:$U2)*Priser!B2


--
---
HTH

Bob


(there's no email, no snail mail, but somewhere should be gmail in my addy)
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Evaluating more than 30 conditions using a formula 1
Help with formula 8
If with countif or counta 3
If and Countif 2
efficiency 3
Cummulative Totals 4
Procedure too large 3

Top