remote desktop issues between 2 vista pc's


S

sacrum

Hey all.

I have 2 vista pc's (1 x ultimate 64 - 1 x ultimate 32). They are both
connected to the same router, one ethernet and one via wireless.

Their local IP's are 192.168.1.10 and 192.168.1.11. They are both in a
workgroup called "netville" and one pc is called ville1 and the other is
called ville2.

When I access network from vista both PCs are visible and Remote Desktop is
enabled on both pc's.

I have configured my router with port forwarding as follows:

NAT:
1. RD - TCP - Wan IP Alias: All Public Port:3389 Private IP: 192.168.1.10
Private Port: 3389
2. RD - TCP - Wan IP Alias: All Public Port:3389 Private IP: 192.168.1.11
Private Port: 3389

When I start Remote Desktop on one of the pc's I fill out computer name as:
ville1 (when connecting from ville2) and leave user name blank. However,
after 20secs I get error message saying can't connect to remote computer.
I'm really stuck now on what I'm meant to do. I wanted to check it locally
first because I will need to connect over the internet soon (I have static
IP for www so what would the computer name be then?)

Can anyone help?
 
Ad

Advertisements

S

Sooner Al [MVP]

You aren't configuring port forwarding correctly in your router. You need a
different port for each PC instead of using TCP Port 3389 for each one. See
this page for help...

http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html

With Vista you need to use either the default TCP Port 3389 or something
starting at 3391 and higher. To test locally from one of your PCs to the
other use the local LAN address. Many routers do not support the so called
loopback using the public IP or Fully Qualified Domain Name.

http://theillustratednetwork.mvps.org/RemoteDesktop/TroubleshootingDiagrams/Basic.html

--

Al Jarvi (MS-MVP Windows - Desktop User Experience)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...
How to ask a question
http://support.microsoft.com/KB/555375
 
S

sacrum

Sooner Al said:
You aren't configuring port forwarding correctly in your router. You need
a different port for each PC instead of using TCP Port 3389 for each one.
See this page for help...

http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html

With Vista you need to use either the default TCP Port 3389 or something
starting at 3391 and higher. To test locally from one of your PCs to the
other use the local LAN address. Many routers do not support the so called
loopback using the public IP or Fully Qualified Domain Name.

http://theillustratednetwork.mvps.org/RemoteDesktop/TroubleshootingDiagrams/Basic.html

--

Al Jarvi (MS-MVP Windows - Desktop User Experience)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...
How to ask a question
http://support.microsoft.com/KB/555375
Many thanks for help. I have changed the router settings to:

1. RD - TCP - Wan IP Alias: All Public Port:3391 Private IP: 192.168.1.10
Private Port: 3391
1. RD - TCP - Wan IP Alias: All Public Port:3394 Private IP: 192.168.1.11
Private Port: 3394

I can RD from the ville1 (Main pc ethernet to router 192.168.1.10) to ville2
(laptop - wireless connection) so I can view my laptop screen. However,
from ville2, the laptop, I cannot view my pc screen...just comes up with
connection error. Both pc's are configured the same way in terms of RD.
 
S

sacrum

Sooner Al said:
You aren't configuring port forwarding correctly in your router. You need
a different port for each PC instead of using TCP Port 3389 for each one.
See this page for help...

http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html

With Vista you need to use either the default TCP Port 3389 or something
starting at 3391 and higher. To test locally from one of your PCs to the
other use the local LAN address. Many routers do not support the so called
loopback using the public IP or Fully Qualified Domain Name.

http://theillustratednetwork.mvps.org/RemoteDesktop/TroubleshootingDiagrams/Basic.html

--

Al Jarvi (MS-MVP Windows - Desktop User Experience)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...
How to ask a question
http://support.microsoft.com/KB/555375
Many thanks for help. I have changed the router settings to:

1. RD - TCP - Wan IP Alias: All Public Port:3391 Private IP: 192.168.1.10
Private Port: 3391
1. RD - TCP - Wan IP Alias: All Public Port:3394 Private IP: 192.168.1.11
Private Port: 3394
 
S

sacrum

sacrum said:
Many thanks for help. I have changed the router settings to:

1. RD - TCP - Wan IP Alias: All Public Port:3391 Private IP: 192.168.1.10
Private Port: 3391
1. RD - TCP - Wan IP Alias: All Public Port:3394 Private IP: 192.168.1.11
Private Port: 3394

I can RD from the ville1 (Main pc ethernet to router 192.168.1.10) to
ville2 (laptop - wireless connection) so I can view my laptop screen.
However, from ville2, the laptop, I cannot view my pc screen...just comes
up with connection error. Both pc's are configured the same way in terms
of RD.

Really confused now...with port forwarding disabled on the router I can
still remote to ville2 laptop....
 
S

sacrum

I think my pointed question is how do I remote to vista pc's over the
internet?


Just can't seem to crack this....I have connected my laptop to another
router and internet provider and my pc is connected to another router and
internet connection. The routers are both configured as follows:

R1 = 1. RD - TCP - Wan IP Alias: All Public Port:3391 Private IP:
192.168.1.10 Private Port: 3391 (different public IP) pc name = ville1



R2 = 1. RD - TCP - Wan IP Alias: All Public Port:3392 Private IP:
192.168.1.12 Private Port: 3392 (different public IP) pc name = ville2

What would be the example computer name for each?
 
Ad

Advertisements

S

Shenan Stanley

<snip>
Really confused now...with port forwarding disabled on the router I
can still remote to ville2 laptop....

If you are using remote desktop only with both machines on the same
network - port forwarding is not necesary, Port forwarding comes into play
when you access the router from outside your private network.

In other words - if you are utilizing the 192.168.x.x IP in your remote
desktop client - you are trying to get onto a machine on the same network
and port forwarding plays no part.
 
S

sacrum

Shenan Stanley said:
<snip>


If you are using remote desktop only with both machines on the same
network - port forwarding is not necesary, Port forwarding comes into
play when you access the router from outside your private network.

In other words - if you are utilizing the 192.168.x.x IP in your remote
desktop client - you are trying to get onto a machine on the same network
and port forwarding plays no part.
Ok understood.

I have managed to get my pc to remote the laptop view over the internet
using router and port 3389. However, I cannot remote back in the opposite
direction even when using port no. 3391 and not 3389. I use public ip:3391
to connect and it simply does not work. This is highly frustrating!
 
S

Sooner Al [MVP]

Did you change the Windows Firewall settings on the PC(s) when you change
the listening port? That is also required.

--

Al Jarvi (MS-MVP Windows - Desktop User Experience)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...
How to ask a question
http://support.microsoft.com/KB/555375
 
Ad

Advertisements

S

sacrum

cracked it!

On the host pc Terminal Services was switched off for some reason hence why
it seemed like a one way connection!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top