Relative Identifier


G

Guest

I have added an additional Domain Controller to my network. When I added it to DNS, a NTDS setting did not appear.
I have added it as Active Directory Intergrated, and Active Directory was replicated. However, I now receive an error," Windows can't create the object (when adding a new user) because: The directory service was unable to locate a relative identifier".
Any help or advice in regards to this would be deeply appreciated.
Thank you.
 
Ad

Advertisements

J

Jerold Schulman

I have added an additional Domain Controller to my network. When I added it to DNS, a NTDS setting did not appear.
I have added it as Active Directory Intergrated, and Active Directory was replicated. However, I now receive an error," Windows can't create the object (when adding a new user) because: The directory service was unable to locate a relative identifier".
Any help or advice in regards to this would be deeply appreciated.
Thank you.

http://support.microsoft.com?kbid=316201

Jerold Schulman
Windows: General MVP
JSI, Inc.
http://www.jsiinc.com
 
G

Guest

Jerold,
Thank you for the article. I have increased the RID block size on both servers, but I still receive the same error. Do you have any other suggestions?
In AD Sites and Services, I can't replicate to this server; when I try to add a new Active Directory Connection, it can't find the new server, even though it is listed in the left pane.
Thanks again.
Al Yaboni
 
R

Richard McCall [MSFT]

Make sure that the sysvol and netlogon are shared on the original server.
That it is advertise the RID fsmo role(use netdom query fsmo) If the fsmo
role holder does not exist the seize the role on the original server. If it
is share sysvol and it is the fsmo RID owner then make sure that both server
are pointing to a single DNS server and are registering records.

Alboni said:
Jerold,
Thank you for the article. I have increased the RID block size on both
servers, but I still receive the same error. Do you have any other
suggestions?
In AD Sites and Services, I can't replicate to this server; when I try to
add a new Active Directory Connection, it can't find the new server, even
though it is listed in the left pane.
Thanks again.
Al Yaboni
was replicated. However, I now receive an error," Windows can't create the
object (when adding a new user) because: The directory service was unable to
locate a relative identifier".
 
Ad

Advertisements

P

Paul Bergson

dcdiag /v /test:ridmanager will test to see if dc has a rid pool has a rid
pool

repadmin /showrepl servername /verbose /repsto /all > c:\repadmin.log <--
make sure to replace servername with your server name

open up c:\repadmin.log and inspect for replication errors. I can almost
guarantee you have problems with replication.

This should give you a start on where the failure is occuring

--

Paul Bergson MCT, MCSE, CNE, CNA, CCA


Alboni said:
I have added an additional Domain Controller to my network. When I added
it to DNS, a NTDS setting did not appear.
I have added it as Active Directory Intergrated, and Active Directory was
replicated. However, I now receive an error," Windows can't create the
object (when adding a new user) because: The directory service was unable to
locate a relative identifier".
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top