RE: WMI Failure


Curtis N. Bingham

Scott et al,

I followed the instructions in the link to no avail. I
checked the registry, the key still exists. When I run
wmic from the command line or try to connect to
root\cimv2 from within wbemtest, I still get an error
code 0x80040154, Class not registered, Facility =

A search for the "fail" text in the logs yields the
following (note the timestamps in the setup.log are
earlier by an hour than those in the wmiadap.log. I
can't seem to erase the setup.log as it is in use by
another process.):

---------- SETUP.LOG
(Fri Jun 25 23:37:00 2004): ERROR: The following WMI CORE
MOF file(s) failed to
(Fri Jun 25 23:37:00 2004): ERROR: Wbemupgd.dll Service
Security upgrade failed.

(Fri Jun 25 23:37:00 2004): ERROR: WMI(WDM) Namespace
Init Failed
(Fri Jun 25 23:37:01 2004): Failed to get ODBC Driver
version size info
(Fri Jun 25 23:37:01 2004): ERROR: A failure in verifying
or removing currently
installed version of WBEM ODBC.

---------- WMIADAP.LOG
(Sat Jun 26 00:24:39 2004.8287707) : CLocaleDefn failed
hr = 80040154

Any ideas?



[MS] Scott McNairy

No idea about what caused it, however how to fix this would be to reinstall
the OS over the top of your current configuration.

In your installation media, there is a winnt32.exe executable in the i386
folder. You can execute it from a cmd.exe prompt and use the /unattend
switch. It will preserve current settings and installations, but you will
need to re-install security patchs when you are done.

[MS] Scott McNairy
WMI Test Engineer
This posting is provided "As Is" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
Dec 14, 2005
Reaction score
Win XP SP2 connected to Windows 2000 server WMI issue

I have a similar problem. As soon as I attach a WinXP sp2 workstation to my win2k server, I get an WMI error on my network connections as follows: Unable to connect to WMI service '\\.\root\cimv2' .

You seem to have a better handle on this than most. All threads I've read on this point to a group policy bug or virus but I need a more easy-to-implement solution and I wondered if you have come up with a fix since you last posted this reply?

Thanks in advance,


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads