Printing failed ,Lexmark X2200 series



Printing failed on my XP SP3 system. Problems seemed to start soon after
SP3 loaded but that may be a co-incidence. At first seemed like a job was
stuck in the print queue which was at length cleared by stop/start of the
spooler. Still no printing. When I try to print the print dialogue box opens
but the printer is not there , only fax. In printers and Faxes if I try to
delete the printer after right clicking then properties and delete I get
error msg saying "...printer has lost comms with server". When trying to
uninstall the driver via server properties option I get error " the driver is
in use " . Lexmark 2200 driver eventually ‘removed’ in add/remove progs, No
Lexmark file/prog is now shown in this window. Reload of driver from CD fails
after clicking "install" ...task manager shows CD to be "not responding"
Loading new driver from Lexmark site fails to do anything after clicking ok
after unzip is completed. Despite unistall the printer icon still appears in
'Printers and Faxes', also the Driver seems to exsist in the Program file
structure, it's folder has 328 files. At system shutdown "rundll32.exeâ€
shows as not responding.
Tried an alternative USB cable with no effect. Unplugging the USB cable
results in the gong sound as does re-connexion.
In Local services have tried stop/starting those items that seemed related
to printing. My printer is Lexmark X2230 , although when I ran the lexmark
diagnostics it said it was X2250 also said no driver was present.
Help; not very computer savvy so plain language replies please.


Read the install instructions from Lexmark. There may be an uninstall
utility available on the website or included with the printer driver

1. If you haven't already done so, download the current driver package from
Lexmark for use with win XP.

2. Disconnect the USB cable from the printer.
3 Uninstall the printer driver(s) since this is a multifunction, you may
have multiple drivers to uninstall.
4. Reboot.
5. Uninstall the USB port and controller drivers.
6 Shutdown and reboot. Windows will usually automatically install the USB
controller and port drivers. (This may be a
multi-step process, with a restart or reboot in the middle.
7. The next step is usually to install the printer drivers, then plug in the
USB cable to the printer. Since this is a multifunction, there may be
multiple driver installs. Usually the printer driver is installed first,
followed by the scanner and fax drivers where applicable.
The printer must also be connected to a source of A/C power. Usually it will
need to be on.

The caviat is that your keyboard & mouse may malfunction during the USB
driver uninstall process if they are connected to USB ports. It's safest to
have a PS2 style keyboard & mouse available if needed.

Another gotcha is that some motherboards require motherboard chipset
specific drivers to get the USB ports to operate properly. If appropriate,
make sure that you have them available.

The key to the process is the uninstall reinstall of the USB drivers. It
would seem that this brakes the old associations between drivers and
hardware, thus forcing new ones to be created/configured.


Hi Cari ,thanks for your post.

I followed the link to Bruce Sanderson's site and tried the instructions
given there. I was not able to make any progress on items 1 - 5 as deleting
the printer in printers and faxes and removing the drivers in server
properties is blocked to me by the error messages I noted in my initial post.
I tried running cleanspl.exe from the resource kit but got the
following message :-
'\\charlie\C$\windows\system32\spool\printers matching the filter '*.spl'
the network path was not found. The specific directory cannot be validated.

Charlie is my computer name. I see there are some instructions on print
service dependencies which I have not progressed to . Can you advise on how I
should proceed from here please.


Hi Chuck ,thanks for your post. There is no obvious uninstall in the driver
folder or on the Lexmark web site , I have E mailled them to see what they
can provide. As mention in my initial post I am not able to uninstall the
drivers owing to the error messages noted. See also my reply to Cari. Any
further thoughts on how I should proceed will be welcome .

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question