Printer Sharing in Vista



I have an Epson Photo R300 printer connected to a desktop running WinXP and
shared on the home network. I have a Vista Home Premium laptop on the home
network and want to use the shared printer. I have gone through the add
printer wizard, selected the Epson printer from the list of printers on the
network, and clicked to install the driver. At this point the wizard stops
responding, and the printer is not added to the Vista laptop.

Any suggestions?

Alan Morris [MSFT]

The XP Epson driver may not work on Vista.

You can either install the Vista driver onto the XP machine (you have to
perform this from the Vista machine targeting the XP machine) or install the
printer on Vista as a local printer, creating a Local Port in the form
\\XPmachine\printersharename and use the R300 driver that ships with Vista.

Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:

This posting is provided "AS IS" with no warranties, and confers no rights.



You seem to be an expert. I hope you will be able to help me. I have been
using my Epson R300 printer for over 12 months with Vista Home Premium. It
worked fine until recently when it stopped working and I got a message saying
Windows does not recognise a usb device. a device has malfunctioned. I
tried deleting the printer using control panel and reinstalling by plugging
into a usb slot. I got the same message.

I contacted Epson on line support and was guided through various procedures
without success. The technician thought it was a Vista problem rather than
the printer.

As the printer is still under an extended warranty, I took it to a local
Epson Repair Centre. The technician tested it and said he could find nothing
wrong but he reinstalled the firmware and reset the counter.

I tried again when I got home and reinstalled the printer using the "add
printer" feature in control panel and i actually managed to print a test page
and then a small word document. However, the next time I tried, it wouldn't
print anything and I got the same message - usb device not recognised.

Any ideas?



Further to previous post, I have tried using "System Restore" to restore my
pc back to when the printer was working ok but that didn't help.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question