Power Policy Manager unable to set active policy

Discussion in 'Windows XP Security' started by Sabo, Eric, Jun 8, 2004.

  1. Sabo, Eric

    Sabo, Eric Guest

    We have a regular user that wants to adjust their power options. They are
    on a Windows XP Professional.

    When they try to adjust the power options, they get the following error.
    Power policy manager unable to set active policy
    "access denied"

    Is there any way to accomplish giving the user want they want without giving
    the user admin rights to their machine?
    Sabo, Eric, Jun 8, 2004
    1. Advertisements

  2. Sabo, Eric

    Sabo, Eric Guest

    Basically, I found what I need:

    If you give the user full control of the following registry keys:

    It works without giving the user full admin rights on the machine

    Sabo, Eric, Jun 9, 2004
    1. Advertisements

  3. Sabo, Eric


    Jun 7, 2006
    Likes Received:
    Thanks for this information


    I had been receiving this message "Power policy manager unable to set active policy" for the last two days in XP Client machine and Windows SE 2003 srv environment. I would like to thank you for providing this useful information. I applied this on client site and it is working fine. i tried to put this in GPO at server end but it did not work.

    Thanks again,
    shakeelr7, Jun 7, 2006
  4. Sabo, Eric


    Dec 13, 2006
    Likes Received:
    power policy manager

    Please tell me what are the values for this two registry keys?
    teodoruc, Dec 13, 2006
  5. Sabo, Eric


    Jan 8, 2007
    Likes Received:
    Hi Sabo, Eric,

    Thanks for the fix. It works.

    Also, teodoruc. The are no keys to set. Just right click on the folders and choose permissions.
    neoluu, Jan 8, 2007
  6. Sabo, Eric

    Brian Hanna

    Mar 15, 2007
    Likes Received:
    Thanks to Eric and everyone.

    You can change the power policy registry key permissions from the domain controller. You don't need to touch the user machine.

    start->administrative tools->domain security policy
    click the registry folder
    action->add key


    on permissions, click your user group, click full control, save
    I did configure permissions, propagate to subkeys

    I rebooted my laptop (may only need to logout, don't know), then checked permissions on the registry keys.

    drill down to the keys under HKEY_LOCAL_MACHINE
    click on GlobalPowerPolicy key
    click your user group
    should show full control, did for me

    Log in as normal user. You can now change the power policy!

    Very helpful thread, thank guys!

    Brian Hanna
    Brian Hanna, Mar 15, 2007
  7. Sabo, Eric

    Brian Hanna

    Mar 15, 2007
    Likes Received:
    Apparently you need to reboot the client laptop in order for the domain security policy to apply permission changes.
    Brian Hanna, Mar 15, 2007
  8. Sabo, Eric


    Mar 10, 2008
    Likes Received:
    solution for the query mr sabo eric

    solution : -
    [font='Arial','sans-serif']1. Navigate to Start\Run and type REGEDIT.
    2. Highlight the HKEY\USERS registry key
    3. From the FILE menu select LOAD HIVE
    4. Browse to C:\Documents and Settings\Default User and select NTUSER.DAT and click OK.
    5. Next you are prompted for a name. Type NTUSER and press enter.
    6. You will now see a NTUSER registry key under HKEY\USERS.
    7. Highlight the NTUSER\Control Pannel\PowerCfg key.
    8. In the right pane you will see Current Power Policy with a value of 0-4, change this to a value of 1 for laptop, 3 for always on, 0 for home ofice.
    9. Highlight the NTUSER key.
    10. From the FILE menu select UNLOAD HIVE. Confirm that you want to close all sub-keys.
    11. From the FILE menu select EXIT.
    12. Log off current user and test registry edit by logging in as a user and check the power options in the control panel. It should be set to always on.
    13. End Task.[/font]
    opendeepak, Mar 11, 2008
  9. Sabo, Eric


    Jun 11, 2010
    Likes Received:
    Thanks Brian

    You saved me hours of work by doing it from the domain controller.

    Eagles1001, Jun 11, 2010
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.