Outlook 2007 will not save POP3 password


G

Guest

I've tried replacing the registry, that seems to be the canned response to
anyone who has problems similar to this, but that didn't work. So I did a
little searching after work.

I removed the HTTP email accounts from Outlook (they worked fine, so I
wanted to isolate the issue) and I found that after deleting the registry
entry (the long one that begins with "S") Outlook never regenerated it when
using just my POP3 account (I let it run for hours) and still never saved the
password. But as soon as I re-added the HTTP email accounts, the [long "S"]
registry entry regenerated, leading me to believe that POP3 email passwords
are not held in that registry folder.

Can anyone help get this issue solved so that I can use outlook for email
retrieval?
 
Ad

Advertisements

P

Patrick Schmid [MVP]

What is your issue? You are describing messing with the registry and I
really don't understand why you were messing with the registry in the
first place.

Patrick Schmid [OneNote MVP]
--------------
http://pschmid.net
***
Office 2007 RTM Issues: http://pschmid.net/blog/2006/11/13/80
Office 2007 Beta 2 Technical Refresh (B2TR):
http://pschmid.net/blog/2006/09/18/43
***
Customize Office 2007: http://pschmid.net/office2007/customize
RibbonCustomizer Add-In: http://pschmid.net/office2007/ribboncustomizer
OneNote 2007: http://pschmid.net/office2007/onenote
***
Subscribe to my Office 2007 blog: http://pschmid.net/blog/feed
 
K

KnightCrawler

Two issues that could be causing pop password problems:

1. Some pop servers don't like when you send and recieve mails at the
same time. So disabling Send when you are trying to recieve can fix
this problem. This is a common problem.

2. A few pop servers need you to login first before you can recieve
your email. In this case the Send needs to be checked.
 
G

Guest

Outlook 2007 will not save the POP3 password on my system too. Every time I
start Outlook, it asked me for the POP3 password even though I had previously
checked 'remember the password'. It asks me only during the first check of
mail after I start Outlook then it doesn't ask again until I restart Outlook.
Deleting the key under 'Protected Storage System Provider' in the Registry
does not fix it. Recreating the e-mail account does not fixed it.
 
G

Guest

I have this same problem on one machine and not the other. After countless
searches, I may just go back to 2003. Can anyone figure this one out? The
registry modifications that MS recommends are not working. I have completely
uninstalled and reinstalled, re-entered accounts, and tried the Protected
Storage registry trick with no luck. Outlook 2007 still won't remember
passwords. I monitor eight accounts, and this is a real pain.
 
Ad

Advertisements

T

tomw

One thing I noticed is that the alpha-numeric sub-key beginning with
"S" under "HKEY_CURRENT_USER\Software\Microsoft\Protected Storage
System Provider" that is mentioned in the MS knowledge article
http://support.microsoft.com/kb/290684 didn't inherit permissions from
its parent in Outlook 2007 (maybe only with Vista, though). So,
instead of deleting the key like the article says, if you edit
permissions of the "S" key so you have change permission it'll allow
the passwords to be saved.

How-to: Close Outlook. Locate the "S" sub-key mentioned in the MS
knowledge article above in regedit.exe, then right click on the key,
then select "Permissions...", click "Advanced" button and put a check
mark in the "Include inheritable permission from the object's parent'
check box, then click OK buttons & exit regedit.exe. After that and
restarting Outlook, it remembered my POP passwords, finally.

I only know this worked on my system: Outlook 2007 on Vista Ultimate
x64. YMMV.
 
G

Guest

I think this is an issue with ALL versions of Outlook- not just 2007.

This issue was addressed in XP some time back as well, but they apparently
have not brought that solution to Vista yet.

Microsoft--- read the posts!!! We are all having this problem with email
passwords using YOUR software on both ends!
 
T

tomw

BTW, it might be a good idea to set permissions back to the original
setting after you get things working since the key is presumably
involved in storing passwords.
 
Ad

Advertisements

T

trekmore

One thing I noticed is that the alpha-numeric sub-key beginning with
"S" under "HKEY_CURRENT_USER\Software\Microsoft\Protected Storage
System Provider" that is mentioned in the MS knowledge articlehttp://support.microsoft.com/kb/290684didn't inherit permissions from
its parent in Outlook 2007 (maybe only with Vista, though). So,
instead of deleting the key like the article says, if you edit
permissions of the "S" key so you have change permission it'll allow
the passwords to be saved.

How-to: Close Outlook. Locate the "S" sub-key mentioned in the MS
knowledge article above in regedit.exe, then right click on the key,
then select "Permissions...", click "Advanced" button and put a check
mark in the "Include inheritable permission from the object's parent'
check box, then click OK buttons & exit regedit.exe. After that and
restarting Outlook, it remembered my POP passwords, finally.

I only know this worked on my system: Outlook 2007 on Vista Ultimate
x64. YMMV.
I have the issue on Outlook 2007 and Vista Business.. this still did
not fix the issue... POS
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top