ONE patch fails to install???!?!?



I just did the mass update on my Windows XP SP2 machine. Everything went
well, but I can't get one of the updates to install:

"Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1

The install history says:


Error Code: 643
Try to install the update again, or request help from one of the
following resources.

Tried installing it 3 times, even deleting the "Software Distribution"
folder where the download is cached.

{B0F400F2-C431-405F-8367-54B20B3FC8B3} 101 80070643 WindowsUpdate Failure
Content Install Installation Failure: Windows failed to install the
following update with error 0x80070643: Security Update for Microsoft .NET
Framework, Version 1.1 Service Pack 1 (KB886903).

Any ideas?


I have to same problem. I've tried all the solutions in the article (except
3, as I don't have a second system to hand), none has worked.

Oddly, my WUTemp folder was empty.


Me too, I've tried all bar option 3 as I only have one machine, my WUTEMP
folder was also empty. This update just will not install. Any ideas anyone?


I had the same problem and the suggested solution by Jose Gallardo did not
I removed "Microsoft .NET Framework 1.1" through "Control Panel - Add or
Remove Programs"
Then (re-)installed "Microsoft .NET Framework 1.1" through "Windows Update".
Ran "Windows Update" again to update "Microsoft .NET Framework 1.1" with
service pack 1 and again ran "Windows Update" to update "Microsoft .NET
Framework 1.1" with the hotfix KB886903.


This worked for me, thanks very much for the suggestion.

If you don't have broadband be aware that this solution involved over 30MB
of downloading!


I'm having the same problem. I tried all of the steps in Article ID 836937
and was not successful. I tried uninstalling .net Framework 1.1 through
Add/Remote Programs and I get an error message "The installation source for
this product is not available. Verify that the source exists and you can
access it." So I downloaded .net Framework 1.1 SP1 from the download center
and got the same error message when I tried to install it. I also downloaded
and installed Windows Script 5.6 which was suggested in another thread on
this community.

Any other suggestions?


FWIW, one of our Senior members had a similar problem recently. I suggested
that he turn off his AV and the installation went ahead fine.


Yeah, I run NAV 2004 and I disabled it and tried installing the patch and it
didn't work.


What the heck is going on here????? I have the a similar problem installing
this update and there is no help anywhere!!!! MSDN does not have any useful
articles. Why would Microsoft release an update that does not install?!!!!
And then have no way of getting help for the failure to intall?

Hellooooo, Microsoft MVP. We need some help here.


Did not work for me. I used the Windows Installer Cleanup utility to get the
..NET Framework 1.1 uninstalled, reinstalled it and the SP 1 and then
installed the update. The update blew up and would not install. I also
uninstalled and reinstalled the Framework 1.1 SDK.

I ask again: Why would Microsoft release an update that will not install?
And, furthermore, why would they not have any support for an update that will
not install?!!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question