Newbie: Remote desktop through firewall



The Question
Can I force the RDC client to go through a specific proxy server?

The background
I have an XP Prof SP2 machine at home and have set-up my router to
allow RDC traffic to pass to that computer. From an Internet connected
PC all works well.

However, as I work away from home a lot it would be very useful if I
could connect to my home PC through our work's proxy when in one of our

Port 3389 isn't allowed through work's proxy so I have changed my
target home PC to accept RDC on port 80 as this is clearly open through
the firewall and modded the router appropriately. Again, from an
Internet connected machine (without work's proxy in the way) connecting
to using RDC client on my work's XP Prof SP1 laptop
works fine. However, trying this from the office doesn't work.

I am guessing the problem is that RDC isn't trying to go through our
proxy server. Is there a way to get RDC to go through a specific

Any other suggestions?

Many thanks in advance
P.S. I have googled to try and find the answer but have had no success
- sorry if this has been covered before.




If you google on proxy tunnel you will find some relevant information. You
would probably be violating your employer's policies to go this route and
might want to think twice about that.


Many thanks GTS - will look into it but am, as you suggest, starting to
feel less like I am trying to find a way to do something I want to do
and more like I am breaking the companies policies which doesn't feel

It is such a shame you can't just add a proxy server to the Remote
Desktop Client configuration and point it at port 80 and flick the
registry on the target machine to listen on port 80 - dead easy.



Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question