.Net Application on share with permission List Folder/Read Data not allowed results in .Net Framewor


B

Bill Fallon

I have a VS2005 VB.Net windows form application deployed to a share drive.
The windows explorer security permissions for this application (.exe) file
is set for Everyone with List Folder/Read Data not allowed. This is done so
that users cannot take away a copy of the .exe file. When I execute the
..exe from the client computer I get .Net Framework Initialization Error,
Unable to find a version of the runtime to run this application. The other
permissions are set as follows: Traverse Folder/Execute File is allowed,
Read Attributes is allowed, Read Permissions is allowed, all others not
allowed. The above settings works for VB6 applications but not the .Net
application. If I set the permission List Folder/Read Data to allow, the
..Net application works fine (but of course a user can now copy the program).

The client and server computers are both WinXP, SP2, with .Net Framework
2.0, peer to peer network. The .Net Framework Runtime Security Policy on
the client machine is set for FullTrust for URL pointing to the share and
has been tested.

Any ideas on how to set this up correctly so the .Net app will run from a
share with the .exe permission set to List Folder/Read Data not allowed?

Bill
 
Ad

Advertisements

N

Norman Yuan

When the desktop app is located on a network share, it does not run on the
computer where the share belongs to, it is copied from the share (hence
being read) to the running computer's memory and run. So, if you do not the
app's files to be read, then you cannot run it. Period. IMO, this is not the
way to "protect" your work from being copied. You need to find some other
means for that purpose.
 
Ad

Advertisements

B

Bill Fallon

It is only the VB.Net application that will not run from a share when the
permission is set to List Folder/Read Data not allowed. VB6 and Fortran
applications run just fine from the share when the permission is set to List
Folder/Read Data not allowed. Why is that the case? Could there be some
special setting in .Net that will make this work?

Bill
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top