Mixed Vista/XP with wired/wireless Network Trouble


G

Guest

Hello,

I'm running a desktop with XP home wired to a Linksys WRT54G wireless/4port
router. I also have another desktop with XP Home (wired) hooked to the same
router, and they're in a windows workgroup called "Mshome" (creatively
enough!). I can share files just fine between the two.

I'm also now running a notebook with Vista Home Premium via wireless (same
router).

I can't for the life of me figure out how to file share between the the
notebook and either desktop. . In my Network and Sharing Center, Network
discovery, File sharing, Public Folder sharing, printer sharing, and media
sharing are all on. Password protected sharing is off.

Problem is that I can't see any of the other machines (XP) on the network.
From the XP machines, I can't see the vista notebook. I've tried restarting,
refreshing, and all sorts of stuff, but no dice.

Can anyone possibly help me? Thanks in advance.

Frank
 
Ad

Advertisements

E

Eric Cross [MVP]

Hello Frank,

Do you have a firewall either Windows Firewall or a third party installed?
If so, make sure it is properly configured for the local area network. An
improperly configured firewall can block file and printer sharing.

Try connecting the Vista machine this way. On the other machine, try one of
the following commands as shown below:

Click Start -> Run -> and type \\Vista

Click Start -> Run -> and type \\192.168.x.x (the ip address of the Vista
computer)
 
M

mircea dan

i had the same problem (almoast)

it can be solved but u got tp be more carefull at details
good luck
 
T

Tom John

i had the same problem (almoast)

it can be solved but u got tp be more carefull at details
good luck

How about supplying some of the details on how you solved it?

Cheers

Tom
 
T

Tom John

This Technet article might help. Work through the steps: http://www.microsoft.com/technet/network/evaluate/vista_fp.mspx

Hey Kim

Thanks for this, I've actually found it before, everything's set up
fine on the two Vista computers... both are connected to the router
(one wired and the other wireless) but can't see each other. I've
turned off the firewall on both computer and all the Sharing and
Discovery is enabled with minimul permissions in the Network and
Sharing Center. I installed OneCare on both boxes, so i think i'm
going to uninstall it and see if that's causing the problem. I'll post
back the results.

Cheers

Tom
 
Ad

Advertisements

T

Tom John

My Solution:

Turned out it was OneCare. There are some options hidden away that
needed to be enabled:

Windows Live OneCare ->
Change OneCare Settinge ->
Firewall connection tool ->
Tick relevant options (Network discovery, file and print settings,
etc) ->
OK ->
Advanced Settings ->
Change file sharing from 'Do not share files and printers" ->
OK ->
OK

Done.

This fixed it all up for me and also allowed the XP box to see the
Vista boxes ok.

Hope this helps someone else.

Cheers

Tom
 
G

Guest

Tom,

That's really good news! Thanks for working this through. I will post your
results (OneCare firewall settings) to a few other posts in this NG for folks
who are having similar problems.

Thanks again!
 
G

Guest

An update to my orignial problem:

I do not have OneCare loaded on my machine (that I can determine). My
notebook came w/ vista Home Premium preinstalled.

I changed my network type to "Private" per Kim's link, and renamed the
workgroup "MSHOME". Via my HP FAQ's, I also found a download for a Link
Layer Topology Discovery download for the XP machine.

Now, I can see the Vista Notebook in my "Mshome" workgroup on the XP
machines, but when I click on it, I get a denial of permissions message.

I can't see either XP machine from my vista machine, except in the "full
map" section of the "Network and Sharing Center". However, even though I can
see the XP machines, I cannot click on them in there. All I can see is their
names and MAC addresses.

Is there anything else I can try?
 
G

Guest

Frank,

I suspect you already know this, but I just want to eliminate this as a
possible issue. You cannot file share through the Network Map, even though
you installed LLTD to 'light-up' the XP machines in your map. To get to the
available shares, right click on the network icon in the task tray, choose
Network and Sharing Center, then choose (in the blue left navigation pane)
the link which says, "View computers and devices."

From there you should be able to see the available XP shares from your Vista
machine. Do you get the permissions error when you take that route?

Thx
 
G

Guest

Having sharing allowed and all the other required share/network settings
correct in Vista and XP machines I could not access Vista shared
foldews/printers from XP machines, however vice-versa I could. Now, after
three days I found the solution:

My Visata machine came with McAfee antivirus preloaded. Both the Windows and
McAfee firewalls were on. As soon as I disabled the McAfee firewall the
network sharing worked as intended!

Doing a little follow-up research, I then turned off Windows firewall and
re-enabled the McAfee firewall, as well as changed the security level setting
in McAfee. At this point I was back to the "no-access" problem so I disabled
McAfee firewall and re-enabled Windows firewall. The network worked like a
carm once again. Now I assume there is an exception check box like "Allow
network folder/pinter sharing" in McAfee's firewall like there is in windows
firewall if you are wanting to use McAfee's firewall instead. Also, this may
be the same issue if you have some other another firewall enabled.
 
Ad

Advertisements

G

Guest

New Gateway GM 5420- Vista Home
(with Windows Firewall and McAfee Firewall ON) / Linksys WRT54GC /
to Dell Deminsion 4550 XP SP-2 (Windows Firewall ON) ALL OK (sharing et al.)
but from The XP to the Vista NO GOOD --XP shows the two workgroups and when
trying to get to the Vista one gives \\**** is not accessible You might not
have permissions to use network resources. Login Failure:user account
restrictions.
Tried with all Firewalls OFF same OK Vista to XP
HELP PLEASE
 
G

Guest

I tried that link already today to no avail--get the same message when I type
in the network block \\****
Thank you anyways
 
K

koze

Do you use passwords or no passwords to logon to the system.

If you don't use PW you have to enable the guest account on Vista and set
the securtity to allow for everyone to be able to work without Passwords.
Ko
 
G

Guest

SGIFL,

I'm sorry you're experiencing trouble. If you're getting a permissions
error, then the trouble is with your user authentication; which means that
your account does not have permissions to log on. Please check to make sure
that you have the same account on both machines; that the account has the
same non-blank password on both machines. I know that you're investigated
your firewalls, but ensure once more that you're not transgressing a
restriction on your firewall.

Please post back with results.
 
Ad

Advertisements

G

Guest

I use system passwords on both Vista/XP-- no user passwords.
Enabled (turn on / off switch) Set up Guest account on Vista--"no joy"
(still only Vista to XP---- NO XP to Vista)
On the Vista the I have the share this folder share name "c" sharing on--
and the share permissions for "c" to "Everyone" (only) full control-- need
more specific help PLEASE--thanks
 
G

Guest

On the VISTA I turned "off" the Guest Account --using only one User Account
In the Network and Sharing Center I turned "off" Password Protected Sharing
"JOY--JOY-
Now I can go from
XP to Vista
Vista to XP
Thank Yoyu All
 
G

Guest

Make sure inside of of your ***network connection (eg Local Area Connection 2
for me...) -> Internet Protocol (TCP/IP) -> Properties -> Advanced -> WINS ->
NetBios Setting -> Default*** is properly selected. This will enable the
systems to talk to each other IF EVERYTHING ELSE LISTED ABOVE IS CORRECT. If
all the above is correct, and this IS NOT, it will NOT be able to talk
between any of the devices, EVEN IF they are on the same Workgroup. Simple
fix. Laterz!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top