Memo Field with Carriage Returns only Displays First Line on Report

  • Thread starter dalecorey1 via AccessMonster.com
  • Start date

D

dalecorey1 via AccessMonster.com

I need help with a Memo field/text box on a report. The memo text box on the
form has the Enter Key Behaviour set to New Line in Field. On the report, I
have the memo text box set to Can Grow/Can Shrink. However, if the user has
entered the text with carriage returns, it only displays the first line
entered. What might I be doing wrong?

TIA.

Dale
 
Ad

Advertisements

R

ruralguy via AccessMonster.com

Do you have the section of the report (Detail probably) set to can grow as
well?
 
J

John Vinson

I need help with a Memo field/text box on a report. The memo text box on the
form has the Enter Key Behaviour set to New Line in Field. On the report, I
have the memo text box set to Can Grow/Can Shrink. However, if the user has
entered the text with carriage returns, it only displays the first line
entered. What might I be doing wrong?

Ruralguy's suggestion of checking the can grow property of the section
is the first place to look; another possible problem is that CanGrow
doesn't work for a textbox if there is *another control* next to the
textbox to the left or right. You may need to move the control up or
down a bit so that it's not on exactly the same level as an another
control on the page.

John W. Vinson[MVP]
 
D

dalecorey1 via AccessMonster.com

Hey! Thanks to both of you for responding! I will check that. I have the
MDB on my Thumb drive. I'll have to load it up and look.

Thanks again!

Dale
 
D

dalecorey1 via AccessMonster.com

Hi! Well, I checked the memo field/text box on the subreport for shrink/grow
and the subreport in the in the detail section of the parent report. All
things are set. Also, in the subreport, I checked to make sure there were no
controls either to the left or right. If I put all the text in one line of
the memo, the text grows and everything prints on the report. If I put
Enters in between each line, only the first line prints on the report.

Any ideas?

TIA,

Dale
Hey! Thanks to both of you for responding! I will check that. I have the
MDB on my Thumb drive. I'll have to load it up and look.

Thanks again!

Dale
[quoted text clipped - 10 lines]
John W. Vinson[MVP]
 
D

dalecorey1 via AccessMonster.com

Nevermind! I just figured it out. I was trying to concatenate the memo with
a bullet in the Control Source (i.e., ="∙" & [ITEM1_NOTE2]), Once I took the
bullet out and just left the field reference in the Control Source, it worked
like a charm.

TIA,

Dale
Hi! Well, I checked the memo field/text box on the subreport for shrink/grow
and the subreport in the in the detail section of the parent report. All
things are set. Also, in the subreport, I checked to make sure there were no
controls either to the left or right. If I put all the text in one line of
the memo, the text grows and everything prints on the report. If I put
Enters in between each line, only the first line prints on the report.

Any ideas?

TIA,

Dale
Hey! Thanks to both of you for responding! I will check that. I have the
MDB on my Thumb drive. I'll have to load it up and look.
[quoted text clipped - 8 lines]

--
Sincerely,

Dale Corey

Message posted via AccessMonster.com
 
Ad

Advertisements

R

ruralguy via AccessMonster.com

Thanks for posting back with your solution.
Nevermind! I just figured it out. I was trying to concatenate the memo with
a bullet in the Control Source (i.e., ="∙" & [ITEM1_NOTE2]), Once I took the
bullet out and just left the field reference in the Control Source, it worked
like a charm.

TIA,

Dale
Hi! Well, I checked the memo field/text box on the subreport for shrink/grow
and the subreport in the in the detail section of the parent report. All
[quoted text clipped - 14 lines]
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top